Teamspeak is disconnected

Please Help

  • make sure you didn’t misspell the address and that you do not have any typos in the address.
  • Ping the address
  • Ask a few friends to try and connect to the server from their end (these friends should preferably have different ISPs to rule out ISP failure), if it doesn’t work for them either it’s increasingly likely it’s a server problem after all and in that case nobody but the server owner can do anything about it.
  • Try to connect using a mobile client using the mobile network (not Wireless LAN), it it doesn’t work again it’s more likely a server problem (at least if your mobile connection is stable and better than edge).

If all those worked (ie. your friends could connect and/or you connecting with your cell phone worked too), then it might be a problem with your network or router.

  • Check your firewall and make sure it doesn’t block TeamSpeak at all.
  • Check your security software to make sure it doesn’t block any ports or protocols (some like to block UDP traffic which is essential for TeamSpeak)
  • Check your router and search for any firewall, SPI Firewall, DDoS Protection, Flood Protection or similar and disable those option
  • Occasionally it helped to disable “UDP Checksum Offload” for the network card. On Windows this can be found in the device manager, properties of the network adapter under the advanced tab.

Just had this issue. Update your teamspeak server, seemed to fix it for me.

I think its not an old server becouse no old server message, if yes the client would write.

Had the same problem this morning. After an update from version 3.9.1 to 3.11.0 the server is running