TeamSpeak server could not validate your myTeamSpeak ID

Hi, I’ve created a selfhosted server which can be connected to without any issues but when clients connect it displays.

The TeamSpeak server could not validate your myTeamSpeak ID. Some myTeamSpeak related services are not available.
Reconnecting might solve the issue.
myTeamSpeak ID is invalid

The server been running now for 3 days but the error still displays, I’ve created the port forwards based on this TeamSpeak Ports the server can communicate to all the addresses required.

Am I missing anything which isn’t covered by the guides, I’m using this on a Windows platform without the firewall enabled.

1 Like

I am having the same issue and was about to make my own post. Please assist.
All ports are open. My only difference in comparison to OP is that I am running linux.

i also had this error yesterday, just logout from your myteamspeak account in ts3 client and login again, that will fix problem

That does not fix the issue.
In my log, it also comes up with a failed to download revocation list. I’m sorry I can’t provide the full word for word issue.
This is a server side issue. The server is failing to download or update the revocation list. I am unsure how to bypass or fix this.

I’m sorry then, i don’t have any idea how to solve that.

Hello do not panic that you are not the only ones having these problems the TS servers receive the exact same error this should be fixed soon by the team.


How can I verify this?
Also, is there an ETA for fix from staff?

Will it require any intervention from my side, or can I continue to build the server with no repercussions?

Further to this, my server does not event attempt to download the revocation list. Is this still a TS3 side issue?

There is no consequence for the server.

And there is nothing you can do to solve this problem we have to wait for the team to correct on their side and everything will return to normal automatically

Do you know if this issue is been raised as a bug if so could you let me know the link to this.

Any status on if it’s been reported and is actively being worked on? Any news on a fix?

We are currently investigating into that issue.


Please try again.


Edit: It is resolved. Thank you.

Thanks : Resolved.