Teamspeak.service: Failed with result 'exit-

It’s not needed to remove this file.

Is there really no licensedata file in your license/ folder or server root folder?

No there is no licensekey.dat or any license file

Any licensepath in that (the ini)?

Where is it located? Can’t find it…

It’s the ts3server.ini but usually not been created by default.

Please run ls -a in your server root folder and share this to us.

. .cache .evos10 .evos6 evos-cli Minecraft resetsurvival.sh
… .config .evos11 .evos7 evosd .nano Survival
??? .esbcoin .evos2 .evos8 evos-tx .profile TestSurvival
.bash_history esbcoin.sh .evos3 .evos9 install q .wget-hsts
.bashrc .evo .evos4 evos.autoinstall.sh Kubo resetkr.sh ystem
buildVersion.txt .evos .evos5 evosbootstrap.zip .lesshst reset.sh

I meant to say in /home/teamspeak/

Nobody in here saw that his server is outdated?
It won’t start because the default license is no longer valid.

@RasmonT please update the server to 3.11 or beta 3.12 first and then try again.

3 Likes

I will try, what files should i replace to update the server? Never updated before so want to be sure i won’t mess this up :slight_smile: .

Could have sworn that said 3.11, so apparently I can’t read :smiley:

2 Likes

You’re not alone.
Only 50% embarrassing… :smile:

Db plugin version 3.11.1. Guess saw that one.

Happens to all of us from time to time.

1 Like

Still messed up even after update… it won’t start

Please set the environment variable TS3SERVER_LICENSE to “accept” in order to accept the license agreement.
Alternatively, create a file named “.ts3server_license_accepted” in the working directory or start the server with the command line parameter “license_accepted=1”.
To view the license agreement set TS3SERVER_LICENSE to “view” in order to print the license to the console.
Alternatively view the file “LICENSE” in your favorite text viewer yourself.

After i replaced the files from 3.11 to the teamspeak directory, this is in the logs and reason of failing to start up the server…

2 ways to do this

(1) Creating the file .ts3server_license_accepted in your TeamSpeak root directory.

(2) Editing line 7 of your ts3server_startscript.sh

COMMANDLINE_PARAMETERS="" #add any command line parameters you want to pass here

Add license_accepted=1 as parameter.

COMMANDLINE_PARAMETERS="license_accepted=1"

For the ts3server_minimal_startscript.sh just add the parameter behind on start.

Example ./ts3server_minimal_startscript.sh license_accepted=1

Both will accept the TeamSpeak license agreement by default.

1 Like

How i can check the license? Im in call with one mate and he is talking about view the license agreement but i have no idea how -_- … that might be issue why is this messing up… if not i think im gonna remove the temaspeak user and reinstall from the scratch …

As you said before already you don’t have a license, right?
This means you can basically download TeamSpeak and run a free 32 slot server.

The server does not require any license.
If you have a license you can use it if not the server will “fall back” to the default license (32 slots).

To start & run the server you need to accept the license agreement (once).
(the server will create the .ts3server_license_accepted file automatically)

To make sure your server always starts without waiting on you to accept the license,
please take a look in what I’ve wrote above. Teamspeak.service: Failed with result 'exit-

That’s it.

I did that… and still same, even no new logs are generated… So i guess only way to resolve this is to delete the teamspeak user, and create it once again with scratch install… cause this is not fixable i guess.

Before deleting everything you can try to download the server files again,
extracting them in a different folder and start the application in there.

Therefore you can see your issue is gone before deleting anything.

(Note) Please make sure any other TeamSpeak server (instance) is stopped before starting a new one.

twitch instagram twitter facebook