Teamspeak wont open after Update

i used Ts3 Client 3.5.6 on my Pop!_OS 22.04 LTS (Ubuntu distro). Then i made an update to 3.6.1 and now it wont start.
It shows following message if i try to open via Terminal:
" ./ts3client_linux_amd64: error while loading shared libraries: cannot open shared object file: No such file or directory "
Reinstalling from Website didn’t work and throws the same error.

If i install it via my application store (flatpack) it downloads the version 3.6.1 and works without any problems.
The thing is, i cant see an option or see the directory to put my dark skin. Thats why i used the .run “installer” from website. Installing as a flatpak wont show me the “style” folder.

Would be nice to get help with installing the new version or to tell me how to install skins with flatpack install, because i hate this bright white design. (Don’t tell me to use teamspeak 5 since i really don’t like the look of it either).

Thanks in advance. Have a nice day.

I just had the same problem. Flatpak works because the required package is probably installed via the installer. If you install TeamSpeak manually, you have to install the required packages yourself.
In my case sudo apt install libevent-2.1-7 solved the problem.