Teamspeak5 simply does not open

try to deactivated antivurs programm, try start ts.
another option is to boot windows in safe mode and try start ts.

Already removed anti-virus and booted into safe mode. No change.

is windows defender active ?

try this

No windows defender is turned off by group policy.

No change.

You tried to DL libcef.dll on the net and put it on the same files of the TS app ? or in system32 ?

Yes I have, No change.

Here is an update for you all. TS5 is running but will only run from a USB memory stick that has TS5 installed on it from another pc.

Scratch that. It DID run but only once and now wont open even from the USB stick.

This is very weird, it’s like if some dlls are not readable, maybe a rights problem ?

Been thinking the same but it’s ONLY Teamspeak5 that is affected. Nothing else on this system has any issues at all.

I have no clue …
Maybe take the rights of the teamspeak files ?

Just had a small breakthrough! I can run TS5 on the affected account as TrustedInstaller!

So it’s a right story

It has to be related to account rights but I have even gone so far as to change ownership and it still wont open. It now ONLY opens if I run it as TrustedInstaller.

Well i don’t have this ■■■■ on my pc so i don’t know.
But if you have to run TS as Trustedinstaller then that mean some files remains under his control

I had the same issue as Zaidain today. (tschat_getPublicRooms)
In my case it was caused by an old version still being present when installing the new version.
So if anyone has this problem, try fully uninstalling (make sure all files on disk are deleted!) all old versions first.

I had this issue too, for me this was the solution: Starting from today, Teamspeak closes directly after starting -> Potential Solution

I do not even have that file.