TS client crashes on MacOS when connecting

Ok, Once the TS app launches it’s time to select CONNECT. When I select CONNECT, the TS app Quits and never does the Connect routine.



I did

I think it’s working now TY for your apiece and help

I’m a tad late, but I still thought it was important to celebrate the momentous occasion of 3.5.7B1’s first birthday! Here’s hoping that it gets to the release channel for its bar mitzvah :‌P


2 posts were merged into an existing topic: Teamspeak 3 Client on macOS missing certificates

You just made my day!

Would it be possible to finally put that link on the downloads section of the website. The version which is currently on it is quite literally not usable for over a year now and as a server owner I have to constantly explain people where to find the beta and why they need it and that is indeed legit.


3 posts were merged into an existing topic: App crashes instantly after starting on M1 Mac

Hi, I am using mac mini m1. In the latest version, when the microphone in the room is pressed, teamspeak automatically closes without any errors. What’s the reason?

Please try the new Client Version: Index

maybe this help you out to fix this. :slight_smile:

thanks :slight_smile:

When trying to join a server on my MacBook Pro running the new beta software build of macOS it crashes. My specs are below.

Mac Book Pro 13-inch, M1, 2020
macOS Ventura 13.0 Beta (22A5266r)
Team Speak 3 Client

1 Like

Thank you, this appears to work.

When I attempt to join a server my teamspeak3 crashes. Any resolution?

This client version will fix that crash.

When I try to connect to any server immediately the whole app is closing with no reason.
I don’t think that my computer is a problem, because I tried on two different computers.

  • I have MacOS
  • I tried to uninstall and install
  • I don’t have any plugins
    Please help me!
1 Like

Thank you!
You’re my savior!

moved by moderator

I have similar issues with MacOS 11.6.7. I don’t get the Set Up Assistant when I download Teamspeak so can’t connect and get microphone availability etc. I managed to input some information into the Connections but got no connection and Teamspeak just crashes. Any suggestions? I’ve downloaded it three times and always times the same.

Here’s a bit of the error log:Jul 7 14:55:11 Kay-Meadowss-MacBook-Pro com.apple.xpc.launchd[1] (com.teamviewer.desktop[8736]): Service could not initialize: Unable to set current working directory. error = 2: No such file or directory, path = /Applications/TeamViewer.app/Contents/Helpers: 20G630: xpcproxy + 23787 [673][86D1F823-583D-36B7-A047-55971A034143]: 0x2
Jul 7 14:55:11 Kay-Meadowss-MacBook-Pro com.apple.xpc.launchd[1] (com.teamviewer.teamviewer[8737]): Service exited with abnormal code: 78
Jul 7 14:55:11 Kay-Meadowss-MacBook-Pro com.apple.xpc.launchd[1] (com.teamviewer.teamviewer): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

This is a screen shot:

Thanks Kay