TS closing alone when opening options

Every time I click on options my TS closes on its own, without showing any error.

I’ve tried to do a clean reinstall, run as an administrator, in compatibility mode, among many other things I saw on the internet to try to solve the problem, but until the present moment I still can’t open the TS options.

Can anyone help me with this?

This should most definitely not happen.
I see you have some plugins installed.
Plugins are reloaded when opening the options.
This could be the issue.
Could you either

  • start TeamSpeak with -safemode or
  • go to %appdata%/TS3Client/plugins/ and delete / move all plugins.
1 Like

I did both, but the TS is still closing on its own.

Then please post at least a log and your main hardware (cpu, graphics card, sound card) and operation system.

1 Like

CPU: Ryzen 5 3600
GPU: GTX 1060 Gigabyte
Sound card: Realtek HD Integrated
SO: Windows 10 Pro v.20H2


2020-12-03 13:45:00.707100|INFO    |              |   |TeamSpeak Client 3.5.5 (2020-11-04 09:57:47)
2020-12-03 13:45:00.707100|INFO    |              |   |SystemInformation: Windows 10 (19042) x64 (AMD or Intel) Binary: 64bit
2020-12-03 13:45:00.707100|INFO    |              |   |Using hardware aes
2020-12-03 13:45:00.771256|DEBUG   |Direct Sound  |   |setting timer resolution to 1ms - 
2020-12-03 13:45:00.837315|INFO    |              |   |*** Time [SPAWN_EVENTCONVERTER]: 130
2020-12-03 13:45:00.871346|INFO    |ClientUI      |   |OpenGL Info: LibGLES, Vendor: Google Inc., Renderer: ANGLE (NVIDIA GeForce GTX 1060 3GB Direct3D11 vs_5_0 ps_5_0), Version: OpenGL ES 2.0 (ANGLE
2020-12-03 13:45:00.986509|INFO    |Addons        |   |Checking for addon updates...
2020-12-03 13:45:00.996518|INFO    |Plugins       |   |Loading plugin: teamspeak_control_plugin_win64.dll
2020-12-03 13:45:00.998520|INFO    |ControlPlugin |   |Control Plugin started, accepting connections
2020-12-03 13:45:01.076590|DEVELOP |Windows Audio Session|   |DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList
2020-12-03 13:45:01.076590|DEVELOP |Windows Audio Session|   |DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList
2020-12-03 13:45:01.304784|INFO    |              |   |*** Time [BUILD_GUI]: 226
2020-12-03 13:45:01.325803|INFO    |              |   |*** Time [SERVERVIEW]: 251
2020-12-03 13:45:01.331808|INFO    |              |   |*** Time [SERVERVIEWMANAGER]: 261
2020-12-03 13:45:01.406132|INFO    |              |   |*** Time [MAINWINDOW]: 705
2020-12-03 13:45:01.406132|INFO    |              |   |*** Time [INIT]: 706
2020-12-03 13:45:01.413137|INFO    |ClientUI      |   |Qt version: 5.12.3
2020-12-03 13:45:01.413137|INFO    |ClientUI      |   |Using configuration location: C:\Users\allan\AppData\Roaming\TS3Client\settings.db
2020-12-03 13:45:01.786476|INFO    |Addon         |   |Addon up to date.
2020-12-03 13:45:01.905584|INFO    |ClientUI      |   |Last update check was: qui dez 3 09:28:40 2020
2020-12-03 13:45:01.906584|INFO    |              |   |Statistics report: Not yet, next report on qui dez 24 09:55:01 2020
2020-12-03 13:45:01.906584|INFO    |Bookmarks     |   |Collecting autoconnect bookmarks
2020-12-03 13:45:02.407039|INFO    |Newsticker    |   |Newsticker next check: sex dez 4 12:28:42 2020 GMT

logs can be found here:

The logs look good…
And for the Windows version the build number would be good to know.

Hmm. everything looks good.
Are there any crashdumps generated?

Yes. How can I send dump files?

As you can’t upload files to this all so great new forum :roll_eyes:
You will have to use a file sharing service of your choice.
Those crashdumps don’t contain any personal information but your Windows username (the one in the path).

I am not sure but it feels like your windows installation is broken.
The call stack is basically a circle until the stack overflows.

@TS.ChrisR may be able to help here more.


try to start ts as admin rights

I’ve tried with admin rights and as a compatibility mode.
But the problem remains.

I upgraded the TS just now and the problem was resolved.

1 Like