TS Server (suddenly stopped running January 30, 2020 and will not restart

I had posted this originally on the server upgrade thread, but I got a message that this is off topic and has been hidden by the community as not relevant to the that topic so for those of you reading this for the second time, but now as a new topic I apologize.

I had a dedicated TS server (free) running for months without a problem on a Windows 7 64Bit computer dedicated to running just the TS Server. It was used for friends to join while playing the game IL-2 Sturmovik 1946. On January 31st I attempted to join the TS server from my TS Client on my gaming machine and the connection failed. I then checked the server lists and my server was still listed as running. I checked the server computer and discovered the server icon was gone from the system tray/taskbar area. Tried to restart the server, but after a few seconds the icon in the system tray would disappear. Checked the server log and it stated that it could not open a licensekey.dat file and that the server would run, but with limited capability.

I searched the internet and this forum and the consensus appeared to be that my server version needed to be upgraded. I downloaded the latest server version and followed the directions for upgrading exactly as was posted. No matter what I have done the server no longer will run. So now I am at a loss of what to do.

I don’t relish the thought of having to start all over again, adding friends and giving permissions etc.

Thanks in advance for any help.

1 Like

You gave us a description but this does not help us to know what cold have caused the issue you have.

Please check your server log 0. You may see the error.
Also update your server to the latest one.

Ps. you can ignore the could not open a licensekey.dat thing. You don’t own a license so the server is telling you that he could not find a license file to use and does use the default license instead.

1 Like

I have similar issue on my both linux servers running on 3.9.1 version.

teamspeak3[4152]: 2020-01-31 18:01:54.409326|CRITICAL|Accounting | |Failed loading default license file!`

It started working with update to version 3.11.0. But I was using old version due on TS plugins works on client 3.1.10 better.

1 Like

Both? Was under the impressions running multiple servers to avoid paying for a license with more slots than no license setup provides was not allowed in the ToS.

1 Like

I just had the same thing, private personal server 3.9.1 suddenly just wouldn’t start. Not sure how long its been like that, I haven’t used it for a few weeks.
I downloaded 3.11 and extracted all of the files over the existing ones and its starting again.
Nothing obviously useful to me in the logs.

2020-01-31 20:22:24.100333|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.9.1 (2019-07-02 13:17:23)
…
2020-01-31 20:22:27.804865|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2020-01-31 20:22:27.804865|CRITICAL|Accounting | |Failed loading default license file!

Screech, how did you manage to jump from it doesn’t work on both of his servers to accusations of licence fraud. Trying it on another box is a perfectly reasonable diagnostic step when something stops working. If he is in the market for a commercial solution that sort of nonsense is going to send him elsewhere.

1 Like

Nobody is using the search function today ?

Anybody update to 3.11.0 first and then report back

3 Likes

It is possible I read too much between the lines, but to me when someone says they have a problem “…on both of their servers running 3.9.1…” to me that indicates the have been running two servers and both now fail to run. Had the wording been more like “… my server stopped working and I tested it on my other Linux server and it also failed …” I would not think twice about it. As you can see I started with a question “Both?”, so not really accusing anything, just questioning, and making it clear why I questioned it.

2 Likes

Add this to the FAQ or a pinned thread?

Maybe even write an announcement that the bundled default licenses of old servers have an expiry date and why, now that the issue seems to hit a decent amount of users?

The error message is not exactly straightforward either and from a user’s point of view, it’s just confusing that a bundled license that they usually don’t have to care about becomes “bad” just by time passing.

Your licensing system is in dire need of some usability improvements, at least for non-ATHPs. I don’t know whether ATHPs actually have to deal with the same issues.

I’m paying for a quite useless 32 slots gamer license (I could be using the free license and I guess nobody would even notice) and I have to renew that thing by hand every year and I also forget about that every year which means my server shuts down every year for a brief time until I notice.

It’s 2020. How can I automate this?

You know that your software’s billing system is not up to today’s standards when it’s easier to buy a submarine online than it is to renew your software’s license.

Please do something about it.

2 Likes

_Mailman, I had the same thing happen to me today. My Server icon was not showing up so I restarted the server and the icon would disappear immediately. I tried updating to the latest version but get the same results. I did a regedit on my registry and deleted all occurrences of Teamspeak, rebooted and reinstalled the server and it still doesn’t work. I tried installing TS on another windows 10 computer but I can’t open the server to configure it.

1 Like

Please post your server log files (in code tags).

Are you sure you have tried to update the server to version 3.11.0 from the official download portal TeamSpeak provides?

1 Like

hi i have download the newest file and yet same problem server go up and instantly went down this is the log

2020-02-01 05:24:22.881181|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.11.0 (2020-01-13 08:12:37)
2020-02-01 05:24:22.881181|INFO |ServerLibPriv | |SystemInformation: Windows 10 (17763) x64 (AMD or Intel) Binary: 64bit
2020-02-01 05:24:23.021806|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2020-02-01 05:24:23.021806|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2020-02-01 05:24:23.021806|INFO |DatabaseQuery | |checking database integrity (may take a while)
2020-02-01 05:24:23.131184|INFO |SQL | |db_CreateTables() tables created
2020-02-01 05:24:23.303047|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2020-02-01 05:24:23.303047|INFO |Accounting | |Licensing Information
2020-02-01 05:24:23.303047|INFO |Accounting | |licensed to : Anonymous
2020-02-01 05:24:23.303047|INFO |Accounting | |type : No License
2020-02-01 05:24:23.303047|INFO |Accounting | |starting date : Mon Jul 1 00:00:00 2019
2020-02-01 05:24:23.303047|INFO |Accounting | |ending date : Wed Jul 1 00:00:00 2020
2020-02-01 05:24:23.303047|INFO |Accounting | |max virtualservers: 1
2020-02-01 05:24:23.303047|INFO |Accounting | |max slots : 32
2020-02-01 05:24:23.537421|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
2020-02-01 05:24:26.006175|INFO | | |Puzzle precompute time: 2656
2020-02-01 05:24:26.021807|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
2020-02-01 05:24:26.021807|INFO |VirtualSvrMgr | |executing monthly interval
2020-02-01 05:24:26.021807|INFO |VirtualSvrMgr | |reset virtualserver traffic statistics

1 Like

I have the same problem, I open the server and… instant crash, icon disapear… Tested in 3pcs, one work, but two no… Whit all versions of the ts3server, what is the problem???

atom n270 - w7 32b (main pc, dedicated to teamspeak, 5 or more years, but now dont works)
dualcore 2 t7200 - w7 32b dont work
xeon w3680 - w10 64b - work
xeon w3680 - w7 32b (virtual) - work

tested all whit 3.11.0, 3.10.0, 3.9.1, 3.9.0, etc…

1 Like

Please make sure you really have tried version 3.10.0.

You would be the first one with this issue if the version 3.10.0 wouldn’t run, too.

https://files.teamspeak-services.com/releases/server/3.10.0/teamspeak3-server_win32-3.10.0.zip

2 Likes

I last successfully started the server (64 BIT version 3.9.1) on January 16th, 2020 and it shut down on 01-31 00:42:30. It had worked fine on January 30th, but when I tried to log into the server on the 31st I could not.
I checked the log files which was running 3.9.1 64 BIT:

2020-01-16 01:25:37.749023|INFO |VirtualServer |1 |listening on 0.0.0.0:9987, [::]:9987
2020-01-31 00:42:30.992195|INFO |VirtualServerBase|1 |stopped

Log File after upgrading to 3.11.0 64 BIT

2020-01-31 01:11:29.914062|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.11.0 (2020-01-13 08:12:37)
2020-01-31 01:11:29.914062|INFO |ServerLibPriv | |SystemInformation: Windows 7 SP1 (7601) x64 (AMD or Intel) Binary: 64bit
2020-01-31 01:11:29.914062|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2020-01-31 01:11:29.914062|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2020-01-31 01:11:29.914062|INFO |DatabaseQuery | |checking database integrity (may take a while)
2020-01-31 01:11:29.945312|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2020-01-31 01:11:29.976562|INFO |Accounting | |Licensing Information
2020-01-31 01:11:29.976562|INFO |Accounting | |licensed to : Anonymous
2020-01-31 01:11:29.976562|INFO |Accounting | |type : No License
2020-01-31 01:11:29.976562|INFO |Accounting | |starting date : Mon Jul 1 00:00:00 2019
2020-01-31 01:11:29.976562|INFO |Accounting | |ending date : Wed Jul 1 00:00:00 2020
2020-01-31 01:11:29.976562|INFO |Accounting | |max virtualservers: 1
2020-01-31 01:11:29.976562|INFO |Accounting | |max slots : 32
2020-01-31 01:11:30.164062|INFO |ServerLibPriv | |failed to download revocation list - count: 1
2020-01-31 01:11:30.179687|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
2020-01-31 01:11:35.804687|INFO | | |Puzzle precompute time: 5753
2020-01-31 01:11:35.804687|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
2020-01-31 01:11:35.804687|INFO |VirtualSvrMgr | |executing monthly interval
2020-01-31 01:11:35.804687|INFO |VirtualSvrMgr | |reset virtualserver traffic statistics

The computer this server was running on without issue was Windows 7 Home Premium 64 Bit SP1 with a AMD 2100+ 64 bit dual core processor. The TeamSpeak server was the only program running (other than the operating system) on this computer without any issues.

I would have use the code tags, but I have no idea how to do it in this forum. So my apologies for not using them here.

1 Like

Use the version 3.10.0 like I mentioned before and report back.

1 Like

The link to the version you gave the is 32 Bit version of 3.10.0. There was no 64 Bit version of 3.10.0 to download.

1 Like

https://files.teamspeak-services.com/releases/server/3.10.0/teamspeak3-server_win64-3.10.0.zip

Just replace win32 with win64…

2 Likes

Worked for me! A HUGE thanks!

1 Like
twitch instagram twitter facebook