TS3 client on Raspbian Pi 4

Hi,

Is there a way of making TS3 client work on the Raspbian Pi 4 (4 gb version).

I’ve tried the 32 bit Windows version, using box86 and wine. And I’ve tried the 32 bit x86 Linux version, using only box86. Non of them seem to work properly.

What is your experience here?

Happy new year.
Best reg. Kent.

there isnt any way to use the client on a raspberry atm. Raspberry PI is an ARM architecture. So the x86 binaries wont work on this system. You could try any android emulator on the RPI. Android has an ARM architecture as well.

Hi and thanks for your reply. I’ve tried installing android on the Pi and running TS3 from there. It works, but doesn’t have all the functions needed for the project, unfortunately.

We need to be waiting for an arm based Linux version then…

Hey,

I’m thinking of buying a Raspberry Pi 4GB just to learn something new. If I wanted to host a TeamSpeak server on it. Would it run well enough for a 32 slots server? I have read the minimal requirements for the TeamSpeak server, however, I’m not sure how it applies if there are more than 10 people connected.

Hey MatiJeBot,

the problem to host on a Raspberry, is that ts server are currently not supportet for ARM cpus.
Teamspeak is compiled in x86-64 and the processor from the Raspberry is an ARM architecture.

You probably need to look for an emulator or something, that translats it for the raspberry

What i found:
https://hub.docker.com/_/teamspeak

and for the minimum requirements for a TS server:

Cheers :beers:

1 Like
twitch instagram twitter facebook