TS3 opens but does not show on screen

Issue: TS will open (No crashes or errors) and display the tab “open” on your screen on your taskbar or that it is currently running. Upon trying to click on the short or trying to pop up through the tab on your taskbar at the bottom of your screen it will not pop up. You can hover your mouse over it and it shows what it would normally be like but otherwise, you can’t use it.
Note: This has started since I have switched from the older version to TS to the current version.

Things I’ve tried:
Restarting (App/PC)
Safe mode (Ineffective due to no errors or crashes)

I will continue to try and fix it to see if I can do it myself then ill let you guys know but otherwise I need help.

Please start the client and then read last client log file and look for errors.

  • Then update your graphics card driver (driver shouldn’t be older than 2 years) and Windows 10 or 11.
  • Install client again Index
  • Try start client with start parameter -safemode or -force-opengl-soft
  • Maybe client opened outside viewable area on your screen. There are ways to move the app.
    Some Programs Are Displayed Off the Screen - Microsoft Support
1 Like

There are ways around them not opening by going through the browser into the app. In response to TS Staff I have checked the logs to find zero errors among the 5 logs that were given but I have found a pattern of code popping up when I could not pull up TS.
“DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList”
“DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList”
I have seen a lot of those in the order of enter, leave, enter, and leave. Some odd codes have popped up like failing to read images several times over and mentioning a forbidden 201?
“server replied: Forbidden 201”

I don’t know how to enter - safemode or -force-opengl-soft but I’ll take a look on what I can find.

On Windows, make a right-click on the shortcut you usually would use to start the client and then select properties. Then add the parameter -safemode or -force-opengl-soft as shown.

1 Like

#moved by moderator

when i open teamspeak it opens on my taskbar but when i click on it it doesnt show and i simply cant use it and cannot do anything, please help me i tried preinstall my pc and it worked for the first day or two then it got problems again… im thinking of switching to windows 10 because i didnt have these problems back then.

@Xnat1onn are you talking about the TS5 client or the TS3 client?
(Because if you are talking about TS5, @TS.ChrisR moved it to the wrong thread.)
Nonetheless, which OS are you currently using?

He is using Windows 11 and this is about TS3 (was tagged before).
So this is the right thread and the first reply is the right one.


1 Like

Hello Everyone, I apologize for taking tons of time but I finally found the reason to this problem and its embarrassing to say the least.
TS3/TS5 works completely fine on my PC but rather decided to activate on an entirely different monitor (which doesn’t exist) for those who do not understand.
-Open TS3/TS5 on input: HDMI2
-TS3/TS5 actually opens on DP2
Do I know why this happens? NOPE! but it happens with various different apps not
My sincere apologies (And thanks to those who have tried to help me)


That’s something I did not have in mind, but on a monitor that doesn’t exist?

But yes it can happen that apps are opened outside of viewable area on a monitor. Will add this to my first post.