TS3 Server on Debian11 wont start Unable to open licensekey.dat

Hey there

i am new to the whole “hosting an own teamspeakserver”. I wanted to dive in more in this topic and started to rent a server by ionos. I followed a Bunch of tutorials for setting up your own TS3 Server on a debian and i never got to the point where i could join the teamspeak nor did i found anything about configurate them. So i wondered if someone may could help me.

I followed the “howtoforge” tutroial and stuck on their daemon-stuff (i dont know anything about it) and as far as i have seen on every over Tutorial this wasn’t named anywhere, so maybe i dont need it.
I configured the Firewall with 9987udp; 30033 tcp, 10011tcp, 10022tcp, 10080tcp; also the firewallsettings in ionosportal are done like this. I tried to start the server and it said it started. i looked with the command “./ts3server” for some informations why i cant connect. In the logs within the folder there isn’t any information wirtten (i opened it with “nano logs” / “nano ./logs”).
“./ts3server” printed:
2022-07-18 07:02:21.092414|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.7 (2022-06-20 12:21:53)
2022-07-18 07:02:21.092623|INFO |ServerLibPriv | |SystemInformation: Linux 5.10.0-16-amd64 #1 SMP Debian 5.10.127-1 (2022-06-30) x86_64 Binary: 64bit
2022-07-18 07:02:21.092663|INFO |ServerLibPriv | |Using hardware aes
2022-07-18 07:02:21.093346|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
2022-07-18 07:02:21.093393|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2022-07-18 07:02:21.093655|INFO |DatabaseQuery | |checking database integrity (may take a while)
2022-07-18 07:02:21.124233|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2022-07-18 07:02:21.124471|INFO |Accounting | |Licensing Information
2022-07-18 07:02:21.124514|INFO |Accounting | |licensed to : Anonymous
2022-07-18 07:02:21.124533|INFO |Accounting | |type : No License
2022-07-18 07:02:21.124589|INFO |Accounting | |starting date : Tue Feb 1 00:00:00 2022
2022-07-18 07:02:21.124624|INFO |Accounting | |ending date : Thu Jul 1 00:00:00 2027
2022-07-18 07:02:21.124654|INFO |Accounting | |max virtualservers: 1
2022-07-18 07:02:21.124706|INFO |Accounting | |max slots : 32
2022-07-18 07:02:21.624563|ERROR |Accounting | |local accounting reports an already running instance, instance will shutdown
2022-07-18 07:02:21.741561|INFO | | |Puzzle precompute time: 599
2022-07-18 07:02:21.742239|ERROR |FileManager | |bind failed on 0.0.0.0:30033; reason: Address already in use
2022-07-18 07:02:21.742420|ERROR |FileManager | |bind failed on [::]:30033; reason: Address already in use
2022-07-18 07:02:21.742521|ERROR |FileManager | |Could not bind filetransfer listen port on default addresses
2022-07-18 07:02:21.742614|CRITICAL|VirtualSvrMgr | |Could not start file manager 258 no network port available

i looked for the License-thing and some said there is a server.ini where a licensepath is written, but there isn’t any file likle this in the folder.

What did i miss or is there another Instrunction i can look through that will goes a lil deeper then the normal turoials of “download it, set a user for it, start it up, there you go”

You placed the file in root of server and restart the whole instance. Done.
If it still does not work then the file you downloaded is broken.

PS your log shows that you already started another instance! you must stop these first before you go on.

3 Likes

Thx for the fast response, i just downloaded the whole package again into root and gave user ts3 new access there and now it worked for me :slight_smile:

This post was flagged by the community and is temporarily hidden.

twitch instagram twitter facebook