TS5 client doesnt appear in the volume mixer

The application does not appear in the windows 10 volume mixer, so it is impossible to adjust the volume independently.

Even after a restart ?

I have restarted 3 or 4 times and even reinstalled the application.

Can you take a screen of the Audio settings ?

Of course there is no problem, I understand that you are referring to the application settings, right?

Well i have no idea, i can reproduce that by switching device but for a short moment.
It’s look like that Windows doesn’t catch the stream.
I have no idea why i’ll make some research.

Do you have any other sound card ? Even the realtek one from the MB, just to check if you switch to this one in teamspeak then look if windows can catch the audio from the app.

Check if the “Allow application to take exclusive control of this device” is ticked in the properties of the soundcard in the Advanced tab.

Maybe I missed something, but judging from the screenshot alone your default device is HyperX… Game, whereas the configured device in TS5 is HyperX… Chat.
When you switch the volume mixer to the …Chat device in that little dropdown on the master channel to the left, there should be the TS5 channel.


Ahah good catch man.
But there is something weird anyway because in the mixer there is no other device.

Oh yes i see, there should’ve been a triangle next to Altavoces as soon as there are several playback devices present. Strange.
As causes I can only assume some hickup with HyperX drivers + Windows, or the device isn’t shown when it’s opened in exclusive mode - which we don’t do hence this one would only fit when there’s also no sound heard.
For the record, there’s no code in any application that’s like ‘show me in the volume mixer’ - as soon as you open an audio stream (excluding edge cases like ASIO or exclusive streams), Windows adds your app there.

My first action would be to look at the HyperX driver app, update if available, and the playback tab in the classic sound control panel. Screenies might give an idea.

Just to have mentioned it, as a workaround, the fader in TS5 audio settings for Output volume should be able to serve the same purpose, and in case there’s no other voice chat running, the hardware crossfader (buttons) of the HyperX.