Unable to set homebase on this server

I´ve just setup a TeamSpeak 5 beta server (with ts-services on GitHub).

In the TS5 client, I can select my server as my Homebase. But when I select it, I get the error (scrn2.png):
unable to set homebase on this server Error [object Object]
My version is beta73, but I tried also beta70 and the same problem.

Chat on server not works and there is orange triangle: currently not possible (scrn3.png).
Does this feature works?

Thank you for any help.

The homebase feature itself works, but TS5 servers are still on development stage. Maybe you did something wrong on the setup, because normally the chat should be working.

And do I understand the concept, that I must set homebase to my own server for working chat?

I don’t know what I could have done wrong, I followed steps and there is not much options to do something wrong, because it is running on Docker so I only start the container.


You can also use myTeamSpeak as your Homebase. For that you probably need to install Beta 70 as the account creation broke with Beta 71. You need to redeem the Beta badge (Code: MULTIPASS) and then you can click the button in the bottom left to setup your chat. There you need to select myTeamSpeak as your Homebase.

For your information the channel chats don’t work if the server is not set up correctly. It would and also should work if the server is set up correctly.

What else does run on that server? If I recall correctly you need to have a working domain and don’t have the port 80 blocked by any other services.

Thanks for many informations :slight_smile:
Yes, I read about problem with beta71 version and I installed beta70. I already have beta badge redeemed and I can use myTeamSpeak as my Homebase. But I thought to working chat on my own server I must set Homebase to the my server.

So I don´t know what I did wrong when I installed the server. But maybe there will be a problem with ports as you said.

On my server there is running webserver (80, 443) and many other services, but when I installed the TS5 server, I edited the “docker-compose.yaml” file and changed default HTTP and HTTPS ports to non-used ports, so there should not be any conflict.

Thank you.

For the chat to work on the server the matrix/synapse part needs to work. If you would set your Homebase on your server the global myTeamSpeak chat would run over your server via federation so that you are not limited by myTeamSpeaks file limits etc. or for privacy reasons.

You can also check the synapse logs and see if there are other problems. I’m not sure if changing the port works. For one of our installation a friend needed to set up a reverse proxy.

Thank you very much for useful informations.
All services are running and healthly. But I will look at reverse proxy. You are right that change default ports probably doesn´t work.

Sometimes the User Credentials are wrong, you can attach to the Matrix Container in the Docker Collection (When you use Docker).

Then you will see, if the Synapse Server declines the Client Requests.

To fix the issue, you can use PGAdmin, but it’s a bit of difficulty.

Another Option is to check if the Matrix Webserver is alive. Should be Port 80 or, 8008.

1 Like

What credentials do you speak about?
If i test connection to 80 and 443, there is something live.

In log of synapse, there is information about starting site:

twisted - 279 - INFO - sentinel - SynapseSite starting on 8008
synapse.app - 49 - WARNING - sentinel - Failed to listen on, continuing because listening on [::]

But I don´t use IPv6. And in the picture above, there is not port 8008 listed…
Here is full log from synapse: https://file.io/UNT0SZISeTdw

EDIT: When I set “bind_addresses” (in /data/homeserver.yaml) to, the warning from synapse log is not showing again, but still not listening anything on port 8008.

There is today´s synapse log: https://file.io/O7aC8iz0rbSk
There is not any errors, it´s look like everything works, but chat still doesn´t work (currently not possible error in TS5 client).
I don´t know what should I do. Thank you very much guys for any help.

I did connect to your server and got this error. The well known file could not be loaded from client.

[2023-05-03 10:17:29.701] [error] Failed to get well known file: status=0 status_message=

Without Matrix Chats & Homebase won’t work.

1 Like

First, sorry for dead linkts to logs.
I reupload the log to my OneDrive. Here is the link: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

To TS.ChrisR: I understand, but I don´t know where is a problem and how can I debug it. I have enabled and accessed ports 80, 443 and 8008 from internet. And all services are running. I tried reinstall it several times, but unsuccessfully.


Your routing seems to have a redirect loop. Are you sure you did not change the docker-compose.yaml
Using any proxy?

— Optional
Can you please share your docker-compse.yaml ? Please remove or censor all sensitive data before you share it?

Alos please traefik log.

1 Like

Here is the log of traefik: traefik-log

Here is the docker-compose.yaml (without censor, I will reinstall the server as soon as possible).

I am sure, I didn´t change anything in docker-compose.yaml.

Yes, I am using this reverse proxy: jc21/nginx-proxy-manager
Trough this proxy, I am forwarding ports 80 and 443 to TS5 server when domain “ts5.trnx.cz” is used. Port 8008 is directly forwarded from router to TS5 server (but I don´t know if it is necessary to opened this port).

There was probably problem with reverse proxy, because the proxy itself generates and manages SSL certificates.
I setup a new server with dedicated IP, so ports 80 and 443 are forwarded directly and not trough proxy.

Thx everyone for help :slight_smile:

1 Like

Welcome to TeamSpeak :blue_heart:

1 Like
twitch instagram twitter facebook