Vps problems when installing ubuntu 20.03

Hello, I am having a problem when I want to install a server in Ubuntu, everything seems to be going well but when it gives me the credentials I get an error message.

2024-02-03 04:05:32.912579|ERROR |Administrador de archivos | |el enlace falló en; motivo: Dirección ya en uso
2024-02-03 04:05:32.912641|ERROR |FileManager | |el enlace falló en [::]:30033; motivo: Dirección ya en uso
2024-02-03 04:05:32.912657|ERROR |FileManager | |No se pudo vincular el puerto de escucha de transferencia de archivos en las direcciones predeterminadas
2024-02-03 04:05:32.912673|CRITICAL|VirtualSvrMgr | |No se pudo iniciar el administrador de archivos 258 no hay puerto de red disponible

Is there a way to change that data or some way to solve it, I have been searching and searching and I can’t find an answer on how to solve it, any idea to change both the port

“Could not start file manager 258 without network”

and be able to configure it correctly?

The error message suggests that there is an issue with binding to the file transfer listener port (30033) because the address is already in use.

You need to find out which process is using the port 30033. You can use the following command in the terminal or command prompt:
sudo lsof -i :30033
This will show you the process ID (PID) of the application using the port. Note down the PID.

Kill the Process:
Use the following command to kill the process:
sudo kill -9 <PID>
Replace <PID> with the actual process ID.

After terminating the conflicting process, try restarting your server:
systemctl restart ts3server

:warning: Ensure that there are no other applications or instances of your server running in the background that might be using the same port. If you have multiple instances or other applications using the same port, you may need to adjust their configurations to use different ports.

1 Like

I have already tried that process, but I only get those ports that are busy in team speak, however my still shows the problem, is there any other way to follow up on this or change the ports, I know how I could do it :frowning:

Even with what was mentioned and following the steps I still get the following error

Hmm, on that second picture you sent, it seems to me that there might be an issue with the command you are using to start your TeamSpeak 3 server.

Can you send the script you use to start the server if you set it up in /lib/systemd/system/ts3server.service?

of course the command is

./ts3server start

my lib configuration is the following

Everything is fine. Your unit file looks good and there is no error in the log of the last picture in your first post. The server is up and running. If you still can not connect, it might be an issue related to the firewall or routing.


I have tried everything, generate a new update, however I have had the same problem with the command.

./ts3server_startscript.sh start

It works fine but when I want to start the private server it still receives the same parameters
included with firewall already added with the command

./ts3server start

  1. Stop using the root account to run the server
  2. Stop any running server instance
  3. Logout from that root user
  4. Login to a non root user
  5. Extract the server
  6. Only use command ./ts3server_startscript.sh start once to start the server and do not use any other command afterwards to start another server.

Now if you really need a private server you should think about using another virtual server in that instance.
Else you should use another server installation and change ALL the ports.

Easiest way is to use an ini file.

To create the ini file start the server with parameter createinifile=1 and you will find a ts3server.ini in server folder.
There you can change port.
Then always start this server with parameter inifile=ts3server.ini to ensure your other ports are used for this server.

But please do not use ROOT account for any of that!


I think your main problem is that you want to run the server twice.
It is running as a systemd unit and you can check whether that instance is running using

systemctl status ts3server

If it says active (running), then the server is, well, active and running already and you won’t be able to start it using the start script.

If you want to use the start script instead of the systemd unit, you first need to stop the unit with

systemctl stop ts3server

Only then can you run ./ts3server_startscript.sh!

So, in conclusion, you can run the server as either a systemd unit or manually, not both.


i think for this u can use cronjob

Hello, it seems to have worked perfectly, but is there a way that when I restart my SV VPS the TS3 service is also restarted so as not to do it manually?

Everything you are asking for is usually achieved through systemd units (You had one set up already…)
Alternatively the same can be done by dockerizing the server (for which an official image exists).