Whenever i talk, everyone can hear my keyboard

I need help,
Normally when i use keyboard, everyone else cannot hear it, but when i talk and use keyboard, they can hear it. How can i solve this?
Thanks

You have the possibility to attenuate your typing noise in your TS3 client settings. There is also the option to suppress other background noises or a possible echo.

twitch instagram twitter facebook