Windows client won't update (beta70)

My TeamSpeak 5 client on Windows (Version 10.0.22621.1105) doesn’t update past beta70. This issue has persisted every since beta71 was released.

I’ve downloaded the update at least 50+ times at this point, as the client re-downloads it every time it starts and it has never succeeded. So I always have to “launch” Teamspeak twice for it to open. There is also no .msi installer for beta71 or beta72 to update manually, so no luck there either.

I’ve completely reinstalled the client already (+ also removing all files I found manually).
There doesn’t seem to be any log created for the failed update. At least not in %localappdata%\TeamSpeak\Logs\Default

Is there any way to successfully update past beta70?
I’ve had no problems on MacOS to update to beta71.

I’d appreciate any help on this issue and am happy to provide any help necessary to resolve this problem.

There are several possible reasons why the update fails.

Here are 3 of them

  • Biggest chance is that something (software or permissions on user) doesn’t allow to write changes to the files.
    ** You may copy the client installation to desktop and run client from there and update then.
    ** If that still fails a software prevented writing files. Check virus etc. software.

  • The update fails because the updater can not write files because the client is still running and files are in use (would be locked)
    ** Try to stop the client manually and start it again instead of using the restart button.

  • The update fails because the updater does crash.
    ** You may see an error in the Windows event viewer


No matter if I start Teamspeak as a regular user or Administrator or on the Desktop it doesn’t work. No other software on my system has an issue to update and Windows also updates just fine, so any external software preventing the update seems unlikely and I don’t think it’s a permission error.

I’ve tried to use the restart button but also just closing and making sure that teamspeak isn’t running and then starting manually; no luck.

I’ve looked at the event viewer and it shows an application error of hotkey_helper.exe every time I start Teamspeak. But no entry after pressing “restart” or starting Teamspeak manually after the update has finished downloading.

Why is where no .msi installer for anything after beta70 to update manually anyways?

Sorry for the late reply. Thought about that but we have no clue when nothing is in event viewer or logged and permissions on your system are fine (as you say).

There is no msi installer that was uploaded and we have an updater that seems to work in 99,9999% of the cases.

What i could offer is a clean Beta 72 Windows client zipped and uploaded.

if that client does not run, then you run into next issue. I fear that your system has this case.


Manually replacing the files works fine for me. Thank you.

1 Like

One thing I could think of is maybe your antivirus has blocked connections to the update server ( ?

The update has downloaded just fine every time. There was also traffic on the connection, so I’m confident that data was downloaded. I’ve also tried to manually extract the update file. The client didn’t start afterwards though.

All prior updates (using the client since closed beta) where working just fine for me.

I’m only using Malwarebytes Pro as AV and it always gives a notification when a website is blocked.

And if was blocked, then no update notification was given at all.

For whatever reason patching the existing files failed and rolled back.

Extracting the next.patch and overwriting won’t work at all. File are patched and not complete in in that file.