3.6.0 – Sound peaking problem

Hell Chris,

thanks for the links.

I’ve tested Teamspeak 5 and the problem occurs even when doing the audiotest in the Teamspeak options. When i record myself and listen to the recording the loud popping is there almost every time. None of the AGC options changed that.
Never tested any TS5 before, so there aren’t any leftovers from previous installs.

But there were more problems with Teamspeak 5:
Everytime any of my friends talked the audio shifts from loud to quiet to normal like a sinus wave. Playing with AGC, AGC experimental and the codecs didn’t change that.

Couldn’t test the VR Headset/Wireless combo quickly. It seems there aren’t any switchable audio profiles and no keybindings for changing inputs/outputs anymore, so that have to wait until Friday evening, but i doubt that it’ll produce any other result.

My Server is running on 3.13.7 on Debian 11, so that shouldn’t be the culprit.

1 Like

When it happens in local test mode (on playback / listening) while echo cancellation is on it will cut off.
That is a known issue.

Thank you for testing TS5 on a server. I will forward this information.


I have also tested it with ts5 and i can validate that this sound issue still appear.
(I followed your instructions regarding TS5)

That answers only a part of my question. But tnx


my TS3 client on my win11 computer went to crap after running the new update last night, was a pain to take it out and put the old version back. it not only had sound issues but also massive fps and cpu drain issues.

@speakmanbro @SeleneWoS @Herysia @jdm84 @Sascha123 @Telmon777 @AKA_Ramstein
Could you please answer this?

If possible can anyone in here share their Playback settings (Tools > Options > Capture) like this?

fun fact…
I’m asking all of these because we know that the issue exists but can only rarely trigger it. like of 16h listening it happens 0-1 times for us.


Hello, thx for looking into the issue, here are my playback & capture settings:
I have a sennheiser game zero headset & mic, with a Xonar DG soundcard, using voicemeter to split voice from other apps, pls mention me again if you need some voicemeter settings.

As well as the ones from my friend:

We’ve been experiencing this when we tried ts5 around april 2021 (according to the badge). And again on this new update.
Currently we rolled back to 3.5.6 and everything sounds good.

We also experience this with another friend that has the same headset & sound card as me, but isn’t using voicemeter (i don’t know his settings)
We’re running on ts3 server v3.13.7 (Linux).

Thx for your time, pls mention me if you need any additional info, so that i’ll receive the email notification.

1 Like

I am using win10 22H2 and logitech Z 625 via spdif. MSI onboard realtek soundcard

im using since few Months a Steelseries Arctis Nova Pro Wireless with the Mic of the headset.
The Headset is connected over USB.

Previous i used Headphones of Senheiser HDR 195 connected over SPDIF and a Wireless Micro Anthlion Mod Mic Wireless connected over USB Dongle. But the settings was the same as it is now.

My Mainboard: Gigabyte Aorus Pro Z390

btw: im using to Nvidia Broadcast for the noise cancelling for the mic. Only the mic.

I have the same issue but the other way around. Since I updated I got the issue, that everyone is super silent unless they talk a while. you can clearly hear that the AGC is increasing the volume but it is very slow.


@SchnitzelMS @HazeBaze

I requested Client’s “Playback” (Wiedergabe) settings.
Client’s Capture (Aufnahme) settings are not related to the issue. :slight_smile:


I posted my playback device. logitech z625 are my speakers. Also using NZXT USB Mic if you want to know

1 Like

sorry then i miss understand something
(habs einfach falsch verstanden xD)

I had this Problem in Windows 10 Pro (x64 22H2).
Now im using Windows 11 Pro (x64 22H2) same issue.

Sorry, late to the party, this week was way too long…
anyway, here are my devices and settings:


I’m surprised you can only rarely trigger it; it happens reliably between me and my friend when speaking before and during pressing push to talk, and when continuing to speak during and after letting go of push to talk. By reliably, I mean you can hear it every 1-4 times you turn the mic on and off while making noise. To make this 100% clear, you have to be making noise into the mic before you turn your mic on with push to talk (so you have to be making noise before audio starts being picked up by TeamSpeak), or you have to be making noise while you let go of push to talk (so you have to be making noise when TeamSpeak stops sending audio packets). It’s the abrupt starting and stopping of the audio stream that seems to trigger it, like it has something to do with the capture (or playback) starting or ending on an audio sample that isn’t a zero crossing in the waveform (or near zero).

I’m using an RME Babyface USB audio interface for playback and capture. My friend is using a Corsair USB headset for playback and capture. Both on Windows 10. We’re both on version 3.6.0, and anyone who is NOT on version 3.6.0 doesn’t hear these artifacts. Similarly, anyone who is not on version 3.6.0 doesn’t produce these artifacts when speaking, even if the listener is on 3.6.0.

I don’t have any strange settings in playback, and I even tried turning off automatic voice volume leveling to see if it would fix it, and it didn’t. I also tried switching from 24bit 48000 Hz to 16bit 44100 Hz, but it makes no difference.


1 Like

I run Fedora 38 and after I updated, everything sounds fine to me but my mic behaves weirdly and some of my friends on Windows 10 and 11 have the same problem. Whenever somebody starts speaking it causes a loud sound for a very brief moment.

I am using a Behringer UMC404HD as output and a Auna CM 900 USB microphone as my input.
I know that you don’t recommend using the music quality for talking channels but it just sounds clearer and we never had issues with it, apart from people having stereo inputs misconfigured so that you hear them only on one ear.

We tried TeamSpeak 5, same issue.

One friend uses the Behringer UMC202HD as his input with an XLR microphone and he has the same issue. We don’t use the automatic gain control so it has nothing to do with it.

1 Like

Hi it’s me again.
We are still evaluating this and we are still not 100% able to reproduce this with all given details.

Many of you mentioned that a downgrade or disabling / not having AGC enabled does not change anything for yourself.

Yes it could be the case that the sender causes the peak

We definitely can see that senders Echo Cancellation is messing with senders voice/loudness for a moment.

Echo Cancellation should only be used when playback happens on speaker (not headphone or headset).

When you have someone in your channel can you please ask him following question(s)?

  • What are his capture settings in Activation and Digital Signal Processing?
  • Does it change anything when he turns off some or all 4 functions in Digital Signal Processing?

Optional question.

  • ( What is his current capture device in TeamSpeak?)
  • ( Does it change when he does use client client 3.5.6 instead? )

Capture Settings:

  • Everyone uses VAD (Hybrid / volume gate)
  • Continuous transmission no sound issues occure

Digital singal processing:

My Settings (using speakers)

Mate 1
See HazeBaze’s pictures

Mate 2

When he uses 3.5.6 the sound issues are MUCH less or DON’T occure anymore

There is a strange problem on my TeamSpeak server. Whenever I or someone else starts speaking, there’s a “pop”/“crackling” sound. But only very briefly with the “microphone activation”. This sound can also be heard with the TeamSpeak 3 client. But it doesn’t show up with people talking through the TeamSpeak 3 client, however almost all of us use TS5. Is there a solution? Otherwise I can’t really use TeamSpeak in the long run because I need it for recordings/streams.

I have the same issue with TS5.
Can also confirm that it’s caused by the user speaking, using TS5.