3.6.0 – Sound peaking problem

Hi I’ve noticed with my friends that after updating client to version 3.6.0 we are all having issue when someone starts talking briefly at the start the audio is loud. It happens when client is quiet for longer time. It doesn’t happens when pause is shorter I think bellow ~5s.

Originally posted on twitter: https://twitter.com/fang_cz/status/1669082152820940809
Also one response from crashlapine here: https://twitter.com/crashlapine/status/1669140242819956738 indicate that I’m not the only one having this problem.


Hey @fang-cz

If you are facing that Problem with your friends, you can downgrade to the Old TeamSpeak Version

Please download the old Client (3.5.6) from here:



Yeah i have the same problem. I have problem in ts5 so i switched to ts3 back and now i have the same problem. I guess it is time for dc.


i have the same problem!!!
Realy annoying blob when someone starts to talk.

since more than one year i have EXACTLY this problem with TS5! That’s the reason i stopped using TS5…
If this stays i am going to stop using teamspeak at all
it is so sad…


Yes one of the reasons why we stay away from TS5 at the moment. Same problem. Unfortunately they have now patched this into TS3 as well. Could someone higher up get in touch about this? Is something being done?

Ja einer der Gründe warum wir uns momentan von TS5 fernhalten. Selbes Problem. Leider haben die das jetzt auch in TS3 reingepatched. Könnte sich hierzu jemand höheres melden? Wird da was gemacht?


downgrading to a earlier version of ts will not work for me and my friends, because we have this probleme since over 1-2 years, and not with version 3.6 oder ts5.

1 Like

I’m glad to finally meet someone who is experiencing the same bug as me.
Back when we got access to the TS5 beta, we were really disapointed with the sound being different there (even if we were connected to the same server). Also, for the same settings (shared accross ts3 and ts5) have a very different output.

Today with 3.6, we clearly noticed something was off, and it sounded like ts5, looking at the patchnote i read * Improved overall compatibility with TeamSpeak Server version 5 and newer. and immediatly thought that they made ts3 and ts5 behaviour matching.

We ended up downgrading to 3.5.6 which is by FAAAAR better.

I understand the idea to have 1 unique processing for both ts3 and ts5, but I don’t get why they didn’t do the opposite: move ts3 processing that worked for decades to ts5 instead of breaking ts3 to fit ts5.

1 Like

have to chime in here. Since today we’re experiencing the same loud “popping” noise when someone starts to talk after a short pause.
Downgrading to 3.5.6 for me didn’t solve the problem, so it has to be something to do with the sending side, the others stayed at 3.6.0
Filed a bug report on Zendesk, but it seems that Teamspeak doesn’t support that bugtracker anymore.

I really hope this will be fixed. I’ve changed the codec to Opus Voice and that seems to be a bit better.
We usually stay on Opus Music for the better quality and deactivated sound leveling.

1 Like

The new version has a very annoying bug where if someone turns their mic on or off while they’re talking, it makes a high pitched chirp (sounds kind of like scissors). Changing codec to Opus Music lessens the bug.

We are aware that this can happen and hope to get this sorted.

To collect some more feedback about your issues:

  • Does this still occur when AGC (Automatic voice volume leveling) under Tools > Options > Playback is deactivated?
  • What playback device (sound card, usb headset etc.) do you use?
  • Are you and / or others talking while this happens? With others i do not mean the user causing this loud voice.

Ps. We do don’t suggest to use Opus Music for Talking. The behavior and calculations are different and or deactivated. This one only should be used for one user streaming something to the channel.


Hi Chris, to your questions:

  • Yes it happens, as SeleneWoS mentioned above it’s not playback issue but rather this peak originates from transmitting side (client who TX voice). And I can confirm that, when I’ve downgraded to 3.5.6 clients on my server that are 3.6.0 still exhibit this problem. Clients that are on 3.5.6 when TXing voice doesn’t exhibit this issue.
  • I use Behringer UMC204 set to 48KHz sample rate for playback and recording, my friends use various mixes of onboard audio ICs from realtek etc…
  • I think I did explanied this in first bulletpoint, the issue is probably on TX side from clients which are on version 3.6.0 older 3.5.6 is fine.

Update: I try to play with codec settings, we do have opus music set as codec in the channel.

Not pointing on anyone with following reply!! We still need to check that issue out!

The thing is that the measurements for AGC has changed.
It has changed in 3.5.x already and did change again from 3.5.6 to 3.6.0 trough WebRTC update.

For our perspective the behavior should be the same as long Listener is on 3.6.0 and sender is on 3.5.6 or 3.6.0.

For the sender we do not use any AGC (leveling) and take what the device sends.This is the case since 3.5.x and hasn’t changed for 3.6.0

…back to the old but same topic
What still could be is that the capture device has it’s AGC active and changes very often and these changes make Client’s AGC freaking out.

Or the updated WebRTC AGC struggles much harder with silence on senders.
But in that case turning AGC off and making sure sender does not have any AGC on his device active should resolve the issue.


I don’t use AGC.
We also use various playback devices. As far as i noticed, the sender causes this sound issue since i can hear issues with 3.5.6 (collegue still had 3.6.0).
At the same time and with the SAME sound settings, in discord is everything fine

Hey Chris,
thanks for trying to solve this.

To your questions:

  • The Sounddevices in my Teamspeak Community are really various. Some use Voicemeeter as a virtual sound card with an onboard or USB device like some Logitech Headset behind it, some use only the onboard, probably Realtek,/USB Soundcard. Some have RTX Voice or what it’s called today between TS and their Soundcard.
    I think i’m the only one left with a dedicated Soundblaster ZxR with the Sennheiser Game One as my Headset with no filters or anything in between.
    The problem is still present when i switch to my Vive Pro 2 VR Headset with the Antlion Wireless Microphone.
  • As written before i’ve downgraded to the 3.5.6 and the “popping” noise was still there from 3.6.0 clients, but not from 3.5.6. clients.
  • AGC (i think in german that would be “Automatische Lautstärkeanpassung”) is always off on my system. Since i’ve reinstalled my system around January there shouldn’t be any leftovers from older versions that had AGC on the microphone side. Can’t say the same for my friends.
    We just tried and having it on or off makes no difference for us, only that the popping sound is way louder with it on.
  • The question if someone is talking when it happens: yes and no. It doesn’t matter, it’s happening both times.

If you need logs, recordings or something to solve this, please let us know.

1 Like

I actually have the same bug as the others, when others start talking there is very often this extremely loud noise, I downgraded Teamspeak again, now it’s good again.

1 Like

Hello Chris, please let us know what we can do to support you guys fixing this problem.

1 Like

My post was moved here but I’m not sure that this looks like the problem I’m having (would help if people uploaded recordings). Here’s an example of what I’m hearing on TS 3.6.0 listening to my friend with TS 3.6.0 on Opus Voice quality 10, when he’s pressing and releasing his push to talk key while speaking. Vocaroo | Online voice recorder

1 Like

On my TS Server we are having the same issue. It’s like my eardrum pops out, every time someone says something. Thinking about ending the 20 year era of TS

You and anyone else in here could indeed try something out (but only in case you do not use a hardware that provides a virtual audio device).

  • Download the TS5 beta client from TeamSpeak Downloads | TeamSpeak
  • Login with your myTS account (use badge code multipass)
  • Make sure AGC (Automatic Gain Control) is enabled under Settings > Audio (Type settings in search bar or press the Gear icon next to search bar)
  • Use the client as you would in TS3


  • On top left type dev into the search bar and open the Developer Tools
  • Enable Playback AGC Experimental mode.
  • Use the client as you would in TS3

Did something change or fix your issue and which one is better?


I will try
but i don’t hope for much though, since i already tested this a year ago without success