Can not start my server (max slot limit reached)

As Fake mentioned it before
There is no licensekey.dat file in needed place and that is all the reason why no license is used.

Please show us a log where the server is “crashing” with the license. All logs didn’t show any crash.

1 Like

the reason is “Received signal SIGTERM, shutting down.” and “too many slots hosted, shutting down!”

but I’ve never used over 128 & 2Servers

I dont know if this help, but you can look here:!?

But now one server tries to run with more than 128 slots or the license is running on another server.
Please follow the link Rikku posted.

Received signal SIGTERM has nothing to do with us.
It’s comming from your operation system. Something (maybe a script) or you told the server process to stop.


Basically, the following solutions have been said (from Rikkus link)

  1. Server did not unregister at the accounting server. Wait 2-3 hours then try again.
  2. A server with the same license is running elsewhere. Shutdown that other server.

Option 2 can not be true
means option 1 that I should just wait while the ts server is offline?


  • You reduce the slots of the server to fit your license.

Example how to do it with ServerQuery commands

login serveradmin yourpassword
use 1 -virtual
serveredit virtualserver_maxclients=128
use 0
serverstart sid=1

  • You make sure license is not in use somewhere else.
1 Like

the problem is the server also crashes with 32 slots (if the license is in the directory)
so as I said as soon as i have the license in it = server crashes

So I wonder how that should be possible
“Server did not unregister at the accounting server. Wait 2-3 hours then try again.”

It doesn’t crash!
It denies to start because to many slots are set in server.

You have to change the slots as said in my last post.

Happens when user kill the process and do not stop it as intended. The server has no chance to unregister all of it’s slots and virtual servers when it just got killed. And accounting hold these for 2-3hours when no such command to unregister came from server.

1 Like

What should i do? i changed the slots to 32 but as I said it crashes automatically (with license and server restart)
to restart the server i use ./ restart

or should the server not be started while the license is in the directory (2-3 hours) ?

Please post the last log of server 0.

1 Like

I did it now (made no difference)


The error came after 1 minute. Means the server started to communicate with accounting service.
And in accounting slots are already registered.

Or wasn’t server 1 started the same time? Can not see it from log 0.

  • So it could be that you killed the process or forget to shutdown your old instance.
    Search for other any other tsserver process on your systems.

  • Or your license is in use on another machine or someone else in case you did send it to someone in the past.

Reminder: Make sure you always stop the server this way! else you have to wait for 2-3 hours.

1 Like

ok I’ve now installed the server completely new + complete server restart (dedicated server reboot)

(sorry i was just busy that’s why the log looks like this) (seen in time)

and i did after the crash i closed it ( ./ stop)

I don’t understand that with the 2-3 hour wait
is meant to start the server (regardless of whether the instance crashes) and then wait 2-3 hours?
and then restart the server? (./ stop +./ start) ?

Would it be possible to delete my existing license and give me a new one? (for the rest of the time)
I really don’t know what I can do anymore
I am really grateful for all the help that has already been given to me
I just don’t really know what else I can do
I reinstalled the whole server and several times the ts3 server and i have never had problems with the license

Best regards Freestyler

Waiting is required when your server crashes/is attacked/etc. so that it doesn’t stop properly.

This means that you don’t run server and wait, but stop it and wait.

Also, as @TS.ChrisR said, check if you don’t have any additional server instances running in background. I’m not a expert and I don’t really own a server, but maybe restating whole server (literal machine, not software) and then waiting these 2-3 hours (or preferably a bit more, maybe 4 hours) will fix this issue. If you don’t have any ideas, why not check it?

But be aware that you’re doing this on your own responsibility!

Is it possible the server application is running in the background?

It’s not needed in any way to install TeamSpeak.
Did you install the application as service maybe?
(this would explain why stopping the server doesn’t work)

i can turn off the server and no I have not activated an autostart function

OK, I’m going to wait a couple of hours now respectively will see tomorrow if the problem is still there

thank you for your interest & help

Are you sure there’s nobody else could have your license file to host his own server?

If you’re able to connect to the ServerQuery interface as you mentioned above, please run the following command and send us the results:

login serveradmin <yourpassword>

Result: Screenshot_1

I looked at the logs again and you can see that the overrun no more is shown

but the server keeps crashing anyway

  • It does not crash! Please stop saying that when it is not the case.
    None of what you showed till now shows any crash.
    You only showed us that to many slots where in use (we explained why and what you can do)

  • And the SIGTERM is not coming from us.

  • So when there is a crash then please show us a log or crashdump OR else follow what we tried to explain when to many slots where reported.

  • When you are the owner of the license and think someone else does use it then please report that to our Sales department and request a new license file and let them make the current one invalid.
    You can do that by clicking the Help & Support button on the right side of that forum.
    You must use the same email address that was used for the license or else the Sales department can not verify that you are the owner. Give them as much details as you can to make their life and yours easier :smiley:


for the first time i had a problem with my ts license (I’ve had this license for almost a year)
but never mind

I just hope that the problem was solved by requesting a new one

I would like to thank everyone at this point who helped me

best regards

twitch instagram twitter facebook