Can not start my server (max slot limit reached)

Result: Screenshot_1

I looked at the logs again and you can see that the overrun no more is shown

but the server keeps crashing anyway

  • It does not crash! Please stop saying that when it is not the case.
    None of what you showed till now shows any crash.
    You only showed us that to many slots where in use (we explained why and what you can do)

  • And the SIGTERM is not coming from us.

  • So when there is a crash then please show us a log or crashdump OR else follow what we tried to explain when to many slots where reported.

  • When you are the owner of the license and think someone else does use it then please report that to our Sales department and request a new license file and let them make the current one invalid.
    You can do that by clicking the Help & Support button on the right side of that forum.
    You must use the same email address that was used for the license or else the Sales department can not verify that you are the owner. Give them as much details as you can to make their life and yours easier :smiley:


for the first time i had a problem with my ts license (I’ve had this license for almost a year)
but never mind

I just hope that the problem was solved by requesting a new one

I would like to thank everyone at this point who helped me

best regards

A post was merged into an existing topic: |CRITICAL|Accounting | |Failed loading default license file!

Hello, I have a big problem with my server my vps burned because of the fire at ovh met I had been able to save the file ts3server.sqlitedb so I bought a vps I downloaded the latest teamspeak server version 64-bit linux I start the server I then stop it and I put the ts3server.sqlitedb file in the FTP I then start and nothing works here are the logs:

2021-03-17 11:13:39.536327|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.13.3 (2020-12-16 14:17:05)
2021-03-17 11:13:39.536448|INFO    |ServerLibPriv |   |SystemInformation: Linux 4.19.0-13-cloud-amd64 #1 SMP Debian 4.19.160-2 (2020-11-28) x86_64 Binary: 64bit
2021-03-17 11:13:39.536484|INFO    |ServerLibPriv |   |Using hardware aes
2021-03-17 11:13:39.537190|INFO    |DatabaseQuery |   |dbPlugin name:    SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
2021-03-17 11:13:39.537222|INFO    |DatabaseQuery |   |dbPlugin version: 3.11.1
2021-03-17 11:13:39.537484|INFO    |DatabaseQuery |   |checking database integrity (may take a while)
2021-03-17 11:13:39.600907|INFO    |SQL           |   |database updated successfully to revision: 33
2021-03-17 11:13:39.602501|INFO    |SQL           |   |database updated successfully to revision: 34
2021-03-17 11:13:39.622064|WARNING |Accounting    |   |Unable to open licensekey.dat, falling back to limited functionality
2021-03-17 11:13:39.622206|INFO    |Accounting    |   |Licensing Information
2021-03-17 11:13:39.622223|INFO    |Accounting    |   |licensed to       : Anonymous
2021-03-17 11:13:39.622233|INFO    |Accounting    |   |type              : No License
2021-03-17 11:13:39.622250|INFO    |Accounting    |   |starting date     : Thu Oct  1 00:00:00 2020
2021-03-17 11:13:39.622260|INFO    |Accounting    |   |ending date       : Tue Nov  1 00:00:00 2022
2021-03-17 11:13:39.622268|INFO    |Accounting    |   |max virtualservers: 1
2021-03-17 11:13:39.622276|INFO    |Accounting    |   |max slots         : 32
2021-03-17 11:13:41.311291|INFO    |              |   |Puzzle precompute time: 1667
2021-03-17 11:13:41.311830|INFO    |FileManager   |   |listening on, [::]:30033
2021-03-17 11:13:41.314920|INFO    |Query         |   |Using a query thread pool size of 2
2021-03-17 11:13:41.387114|ERROR   |VirtualSvrMgr |   |loading VirtualServer(1) failed to start, error: max slot limit reached
2021-03-17 11:13:41.387372|INFO    |Query         |   |listening for query on, [::]:10011
2021-03-17 11:13:41.387602|INFO    |Query         |   |listening for ssh query on, [::]:10022
2021-03-17 11:13:41.387713|INFO    |Query         |   |listening for http query on, [::]:10080
2021-03-17 11:13:41.387774|INFO    |CIDRManager   |   |updated query_ip_allowlist ips:, ::1/128, 
2021-03-17 11:13:42.655824|INFO    |              |   |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated

There’s obviously no question about the issue.
Your server stopped caused by the fact your virtual server has more then 32 slots assigned.

|INFO    |Accounting    |   |type              : No License
|INFO    |Accounting    |   |max slots         : 32

Do own a license you may forgot to move into your root path?

Unable to open licensekey.dat, falling back to limited functionality

If not you’re limited to 32 slots as mentioned above and your virtual server has too much slots assigned.

You have to lower the slots of your virtual server down to 32 slots or use/parchuse a license.

To lower the slots do the following steps:

  • start your TeamSpeak server instance
  • connect via Telnet/SSH as server query admin - login serveradmin <password>
  • select your virtual server (probably ID 1 - use 1)
  • edit your virtual server - serveredit virtualserver_maxclients=32
  • start the virtual server - serverstart sid=1

Check your logfile after and make sure there’s no error anymore after starting the virtual server.

1 Like


I can not do this since my server does not work so the telnet console cannot work if a teamspeak staff could help me since the problem mainly comes from the new update

This has nothing to do with the update. The server you are trying to start has to many slots for the default license.

We can not give you 3rd party support so we suggest SSH/Telnet connection to solve this (you see the ports in your log).
Open the port or do a connection from the machine itself and you do not need to open a port.


its good i solved the problem i used navicat to open the ts3server.sqlitedb file and i changed the number of slots to 32 and its solved issue using navicat it does not harm the ts3server.sqlitedb file?

Touching the database directly is not supported.
There is always a risk to destroy it.

1 Like

after I had no other choice since the server did not want to start the only solution was to open the file and just modify 64 slots into 32 slots in itself I did not modify anything big

You just could have logged via ServerQuery as Fake mentioned and gave an how to and change the slots.
It’s not needed that the voice server started.

The use 1 -virtual as an example allows to select the voice server as long the server instance is running.
Then you could’ve performed command serveredit virtualserver_maxclients=32 followdy by serverstart sid=1

Threads merged


So as i said in the title, i can’t run my teamspeak3 server because server properties have 128 slots, my license expired, i deleted licensekey.dat from the folder.

I work on dedicated windows server.
I have many IP address, so i set ts3server.ini with the IP i want to work with ts3.

Please help me.

For an expired license you have to contact the sales department.

I want to run back to 32 slots, i don’t need a license anymore, but my server is off so i can’t modify 128 slots, and put back to 32 slots. I don’t need help about an expired license. I need help to run my server and put back the 32 slots…

Take a look into the thread and especially my answer and the answers from TS.ChrisR.

moved by moderator

I update my TS3 server exactly with instruction here Update / Upgrade a server after all, server start and running but can’t connect with them. When I remove my ts3server.sqlitedb and then start server I connect with them without any problem. What could go wrong? What to do to restore my server settings?

Can you share your server log and your Client Log pls? :slight_smile:

It look like license problem. I have free license for 512 o 1024 slots (don’t remember) for non commercial. How can I get back to work my server?

twitch instagram twitter facebook