Can't connect to TS3 Server outside of my network

First of all, im going to make a list of the software versions im using:

  • Client: 3.5.6 Windows and 3.5.6 OS X
  • Server: 3.13.3 Windows and 3.13.3 Linux

I created a TS3 server in my Windows server and all. It started and everything was “working”. I connected inside my LAN and it connected. I opened the ports for the host as shown below ( is the internal IP of the windows server):
and when i was going to try connecting with my external IP, well, it couldn’t connect.
I went to disable the Windows firewall just for testing and still nothing. Opened the ports in the advanced settings of the windows firewall, all with the correct protocols, but still, nothing.
Wasn’t working at all, outside the network.

I then made an Debian VM and created a new TS3 server. Connected within the LAN network to see if it was working and indeed was. Then i changed the WAN ports destination and tried to connect, but it also wouldn’t connect.
I also tried from the mobile network through my phone, and it also couldn’t connect.

I am facing this problem for quite a while and i have no idea what i can do more to make it work.
Does someone know what can be happening?

Please take a look here: [Solved] Hosting a TS3 Server at home - #12 by Rikku

i’ve already done everything on the link you sent.
it seems its not a windows issue though, since the debian VM also had its problems on the connection.
if it had any problems on the firewall, wouldn’t it also have problems connecting inside the LAN network?