Have to press PTT button twice

I am wondering if anyone knows of a recently introduced bug (or some setting that has gone awry) that is causing me to have to treat the push-to-talk button like a “toggle” vs simply press, talk, release.

In the last 10 days or so, I have run into a problem that if i press the PTT button, the button “remains pressed” even after I let go. Thus, I continue to broadcast even though I do not wish to. I have to press the button a second time, when I am done talking, to make it stop capture.

Been using TS for many many years and have never run into this. I have tried uninstall, reinstall as well…no difference.

Thx in advance for any insights!

Late Update: Sorry, i forgot to mention that when I attempt to set the PTT key, I have a number of issues:

  1. When I first to to the capture tab, select PTT radio button, i can select a key, but the little grey popup never goes away after selecting “a key”. If I try to get ride of it by pressing any other key, like esc, or a mouse click, it captures that second key/click as part of the PTT key.
  2. Other times, i hit ESC to clear the key, and it will no longer capture any key (see attached). You press my preferred PTT key (right ctrl key) and it no longer captures it (like it did one time in bullet 1). Something is very much amiss. It is as if TS is only recognizing every key BUT right ctrl.

I know I can select a different key, and it will work, but just wondering why, all of a sudden, Right-Ctrl no longer works. I have this set up in a number of configs in my game pad, and would prefer not to change them all if possible.

My Guess you have software running that may block the key release from being send to other applications (any application running in admin mode can do that).

If no key release was send then the client still thinks you still hold and waits for a release.

Edit// Above text was before your edit but still could explain it. I have no other clue here.

1 Like

I appreciate the response, but don’t think that is issue (and i have not added or changed an software in many months…this is a new change, after recent update).

So, it appears that TS is no longer permitting the right-ctrl key to be selected. I have assigned a different key, and it works as always, but I would have preferred to keep it as is, as I have to change that setting then in a couple other places. Perhaps maybe not the end of the world, but I would think TS (the company) would want to be aware, and perhaps they are, and did this for a reason (ie not thinking folks would use right ctrl as a PTT key???)

This works fine here with latest beta client 3.5.7

I have no clue what could cause this on your system and you wrote it worked before.
So something has changed and there was no client update from our side. This is why i don’t think yet we have a bug here :confused: At least that long it works here and there not more reports coming for this.


Anyone else reading my reply could try it? Maybe it happens on some systems and not on all.

1 Like

yeah…not saying it is an upgrade, etc…but I did finally accept an update right before. I cannot explain it.

twitch instagram twitter facebook