Hotkey on Gamepad/Joystick/Steering Wheel can not be set

Agree with the previous posts - TS doesn’t seem to be interested in fixing issue.

If the source would be available I would first have a look at the “Gamepad and Joystick Hotkey Support” plugin.

Could it be that it doesn’t support newer controllers with a lot of identifiers (buttons)?

P.S: Furthermore the same button is working flawless in discord :wink:


I have a Logitech G29 and when I try to set up my hot key for PTT, it reads it (circle button as button 3) but doesn’t accept it. It accepts any other buttons I use when I click my mouse or type on the keyboard. Am I doing something wrong?

Well i have no info about that but, for me they will not do anything about that until the release of TS5.
The only way is to use a key emulator at this time : antimicro or joy2key.

I’m going to drown up an old thread to see if anyone has any fix yet. I have a Fanatec CSW 2.5 with a universal hub. If I plug the wheel in to usb 2.0 port it works. If I plug USB 3.0. TS3 doesn’t see the button release…

Discord works fine. I wish TS3 would work on their ■■■■ since so many of us pay every month for their service.

1 Like

Did anyone ever find a solution? Ive been dealing with this for over a year. I looked for solutions and ended up using a 3rd party app to read the buttons from the controller and push a button on my keyboard for PTT however in many games this causes the UI go to haywire as it switches from xbox to pc to xbox.
It blows my mind in the day and age where Teamspeak is struggling to stay relevant that they are giving the big middle finger to the users they still have. As an owner of an large teamspeak server, this hurts.

hi , i have the latest version of TS3 as i was install it on my new system windows11 , and i try to use my gamepad and joystick to set hotkey for the PTT button , but it was never release the button i press and dont let me save it just if i click on any key on my keyboard it is saved as hotkey.
i have WINWING throttle and joystick connect direct to my pc USB port .
before i was use the same joystick and throttle and TS3 on my windows 10 and all was working good .
now i am stack and can not set any PTT hotkey from my game pad joystick .
please help asap , thanks

Have you the “Gamepad and Joystick Hotkey Support” plugin installed and running?

Yes. and i try to uninstall it and download it again and install , but nothing change
it recognized my key on the hotas but the windows of the hot key is not diapered until i press any key on the keyboard , and then it save the hotkey as joystick + keyboard

i must say that it is look a problem of TS as all the other software that i use for communication like SRS Radio and other is work very good with PTT hotkey on the same system .
as i was explain it was start happen from the moment i was install Windows 11

This is clearly a TS problem, I was a long time trying to understand what is wrong with the code of my Arduino firmware and essentially it’s all right, I guess the key release event that TS is waiting for depends on the driver or interface the device is using, but this should be clearly supported since it is for any other game or application, or may be not anymore in windows 11. Kind of funny this is here for so long!

ANSWER: Press the button and while the gray funny box is there unplug the usb cable, this does the job to me and sends to TS the information that the key is released. In the case this is the way to assign keys I suggest to put this in the manual.


According to the description, the “gamepad and joystick hotkey support” official plugin is supposed to work with virtual HID device.

I have a software that when I press a physical joystick button allows to send a vjoy button press.
But it seems teamspeak never sees the vjoy button but always catch the physical one instead.


The developers don’t seem to be interested in this topic anymore.
Workaround - Plug the controller directly into a USB port on the PC and not into a USB hub. That worked for me.

1 Like

When I try to map speak button on my accuforce wheel, I recognized the putting I press, but then it sits there and requires me to press a second button, requiring me to use both buttons to talk.

If I just choose a key on my keyboard, it accepts one key just fine.

Any suggestions? I would really love to be able to use a button on my Accuforce wheel to talk while driving.

Thank you.


Just installed TS3 on a new build (TS3 has worked fine on my old build).
When I try to set the PTT hotkey from my HOTAS, it recognizes it but when I hit Enter (or left mouse) to save it it always adds +enter (or +left mouse button) to the selection.

Any suggestions? Can hotkeys be manually edited in one of the files? If so, where and which file.

I had similar issue back in 2017 when “Gamepad and Joystick Hotkey Support” was new.
It was solved by module developer. Now I upgraded HW (using ASUS ProArt x670e motherboard) and problem reappeared.
Original issue was with parsing USB device names, especially with virtual functions as far as I remember, here is original thread:

Hello TS3 Users,

I, am getting an issue which cropped it’s head up a few days ago. when I goto Program my Joystick PTT key on Comm switch on the joystick, I see the button press but the OK is either greyed out or when I press it “Mouse Button1” gets selected along with my comms key button press from my stick…

I have another friend who is having the issue but none of our other frineds have this issue…

Currently, I am using Win 11 22H2 (OSBuild 22621.1702) TeamSpeake version: 3.5.6 (11/25/2020 08:53:42)
QT Version: 5.12.3

I, was using this same version a few days ago and I was able to program my PTT key no problem. I did reinstall Windows but I regularly do that and never had an issue the past few years with this happening…

It did happen some years ago and I solved it somehow but it remains a mystery as to how to get this solved…

I tried Google searches and just similar issues but not my exact issue… so if you know how to fix this I am all ears…

thank you

Problem is that “Gamepad and Joystick Hotkey Support” freezes after first input.

To verify this:
When you first time try to map PTT it will detect button down event and freezes, never detecting button up and waiting for some other key to add to combo.
If you retry, it will never detect any button/event until addon is restarted (disable/enable).

If it happens to you with PTT already mapped somehow, TS will just continuously transmit after first button down.

Solution is plug your joystick to USB 2.0 port. For me it works

1 Like

moved to existing topic


I’ve been havign this isssue for so long, i have done a workaround with third party program.
But, why i turned here is because I want to get the attention of the devs, so what happens is that when a button is pressed it does not register the release que. Because, (and i dont know if this is the reason to 100% but feels like it could.) on my joystick there are other buttons that are (ON)-(ON) which means they are always being depressed, maybe the TS PTT option thing does not recognise it and dont want to exit that menu because of that?

So here i am, i have no idea how to get the devs attention because they dont have a support page.

Thanks for reading

Tried it, even bought USB 2.0 header for this, no avail. I think reason is USB 2.0 on my motherboard is hooked under USB 3/USB 4 anyway.
As I’m 99% certain it has something to do with USB device addressing it is still no go :frowning: