Hotkey on Gamepad/Joystick/Steering Wheel can not be set

I wanted to ask for help with Teamspeak. I have been on and had everything working perfectly, but I recently got a new computer and when I reinstalled Teamspeak, i am having issues with push to talk. I use push to talk because i use speakers for my engine sound and don’t want to annoy everyone. Before, I had no problem assigning my ptt button but now it wants me to do a button combination. In other words, I assign my ptt button and then have to also hit another button, either mouse or keyboard. I have Googled and spoke to several people for a fix and can’t find one. Has anyone, by any chance, heard of this happening?

When another button is required, then the first device does not send any key up event.

I assume (because you gave zero details about any operation system or device or client):
You are using a game pad or joystick or steering wheel.

Check your drivers, if it worked before this might fix it.

1 Like

I am on Windows 11 and using a dedicated ptt button. It is for iRacing. It recognizes the button and assigns it but wants a second button pushed as well.

As i wrote whatever your device or software or etc. sends is a key down event.
But the dialog waits for any key up event to close.

When mentioned key does not send any key up event, then the dialog won’t close.

1 Like

Do you have any idea why this would be happen on a different computer? It worked perfectly before. Same button and also Windows 11 before.

Maybe missing drivers or later driver versions for that device causing a different behavior.

But no I don’t know why.

1 Like

Yes I have an idea. I’m confident it has something to do with USB device name reported to TS. There was EXACTLY same issue few years back with virtual functions on USB controllers (see above) and now it seems to be related to more complex USB architecture and most likely to USB4.

As written above, you may try to use USB 2.0 ports and it MAY get better because of more old school USB device name/path.

Unfortunately, there is deafening silence from devs for looong time :frowning:


Thank you for that information. I will pass it along to my tech buddy. I am hoping to get this figured out.

1 Like

In the past I have used the add on for joysticks/game pad to use my racing wheel for push to talk, but now it is insisting on a combo of wheel and keyboard which is near impossible when racing in VR. Any ideas why it wont let me use only one button like in previous versions? Or know of a work around. both the new TS and old ver 3 have the same issue now!

1 Like

Why don’t you do it with the PTT button? New computer set up, all controllers tested, always want second button, mouse 1 or whatever. So many people have this problem and can’t understand why nothing happens.

I answered that already.

As long your device or driver won’t send the key up event, then the dialog won’t accept it as a hotkey.
The dialog is build that way and for most users this is what is to expect or else they must setup each key twice with a key down and up event.

We won’t change that and make it complicated for everyone just because for whatever reasons a device won’t forward it’s key up event.

1 Like

At least in my case problem is that after first key down event entire plugin freezes. That’s why there is no key up event, or any other event at all until plugin is disabled/enabled.