How to change voice port

I have a teamspeak server and I am wondering how to change the port It uses, I’m running windows 10 and I have already tried putting virtualserver_port and default_voice_port in to the parameters but both dont seem to affect the port that is used.

You can change the port via. telnet or SSH for example.

(1) Login and choose your server, e.g. use 1.
(2) Edit the server parameter

serveredit virtualserver_port=9999

How to connect?

For example via. console or Windows command prompt.

ssh [email protected] -p 10022
telnet 10011

Enter your query password, choose the server and edit it (see above).


Should that be possible on a single main-server with no license? I have tried that with no luck.

1 Like

Of course.
You can change the port of your virtual server no matter you own a license or not.

What do you mean with no luck?
Could you successfully login as admin server query?

1 Like

SSH with query works fine.

I can’t remember exactly what the return response was to my attempt, but I can give it another try.

I ended up making an ini-file, but what didn’t work either for the voice-port. Only for filetransfer-ports etc.

1 Like

The UDP voice port is not defined in the server ini file.
It’s been set in the database (file) the server uses.
It has nothing to do with the ts3server instance at all.

You can edit it via. the query interface as I mentioned above.

1 Like

Edited …

Oh, I was missing the ‘restart server’ to complete the changes :slight_smile: Works now!

1 Like

In the ini, and command line parameter, you can only change the default_voice_port, this default is only considered when making a new server. Once you have made the server it will use the voice port it was configured with unless you edit that server, as @FakE explained above.



Nice to know! Thanks :slight_smile:

1 Like

Hello everybody,

i just installed TS Server 3.13.6 on Ubuntu 20.04 LTS following this manual to use it in my LAN and with family members over the internet:

I think everything is running fine, but i cant change the Server-Port.

This is how i try to change the port numbers.

stop ts3 service: systemctl stop ts3server.service
-> TS Client disconnects immediately
edited the ts3server.ini in /usr/local/bin/teamspeak3-server_linux_amd64/
-> changed value default_voice_port= to another ramdom port number like 33333
-> also changed all other port values in the ini file to 33334, 33335, …
-> saved the file
-> i reopened the ini to check changes in the ini
start ts3 service again with systemctl start ts3server.service
-> TS Client reconnects immediately without the need to change the server port

Any Ideas whats whats the problem?

Oh, and of course, /etc/systemd/system/ts3server.service points to /usr/local/bin/teamspeak3-server_linux_amd64/

Thanks for your support.

Since you have already started the server one time, the default port is stored in the database. You have to change it via serverquery (telnet/ssh).

Here is a link where someone once wrote a short instruction: How to change voice port

Thank you, this helps to understand the problem.

Tried this howto, but i failed, because i never created a password for serveradmin till now, so i wasnt able to login. Blank password doesnt work.

Found this how to reset serveradmin password:

I started ts3 with the minimal script and the serveradminpasswort switch and without the inifile-switch. TS3 started but not as a service.

Then, i connected with ssh and logged in as serveradmin and tried the serveredit virtualserver_port=33333 command but i got:

error id=1538 msg=invalid\sparameter

Just to let you know…

I reinstalled TS3 and everthing is working now.

twitch instagram twitter facebook