I cant start server 3.11.0 (CPU does not have POPCNT)

Interesting. My Windows Server 2008 box had been running for several months on 3.9.x. It was only after I noticed it crashing repeatedly that I checked for updates and updated to 3.11. I don’t see how your explanation makes sense in this case. Please clarify.

Yes I get that. It was reading that thread that made me realize that TS is NOT a standalone product. What all is involved in downgrading to a x86 version from a x64 version? Is my database still usable?

Some corrections, with 3.10.2 either 32 or 64 will work fine without POPCNT support. 3.11.0 32 & 64 bit versions require POPCNT. Based on beta release notes: Starting with 3.12.0 32 bit will again not require POPCNT, but the 64 bit will continue to required POPCNT and should have better error messages to report this. If running on a VPS you may have to run the 32 bit even with a 64 bit processor that by spec does support POPCNT due to the virtualization layer removing some instructions from the CPU the VM sees.

Also looking like POPCNT may only be required for Windows 64, if I’m reading that right.

3.11.0 does not require POPCNT on all operation systems.
Only Windows requires this feature.

In 3.12.0 only 64 bit version will require it. While the 32 bit version of the server works without.

I general I’m not a fan of downgrading. But in the case of 3.11 that never started going back to 3.10.2 is not a problem (assuming it is failing before any DB update code was run, if there was any). I run my servers on Linux and not looked too closely at the issue with Windows here to fully input on that.

Generally I never run a version of the database that ran with a newer software than the current version running. For those downgrades I would restore a backup last run with a software version =< the software version I plan to run.

I would not say they need to drop to 32 bit while going down to 3.10.2, just because it doesn’t matter, they can run which ever they normally would, they just need to be aware of why 3.11.0 failed to run for them and be aware that the plan going forward with 3.12.0 will require they run the 32 bit if their
Winodws server can not access POPCNT instructions (either CPU lacking or Virtualization stripping).

1 Like

Server 3.12.0 Beta 3 is live.

Please download and use the 32-bit Windows version.


I have an issue when i start my server.

This is the log, i dont see any problem:

2020-03-17 09:19:07.400643|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.11.0 (2020-01-13 08:12:37)
2020-03-17 09:19:07.400643|INFO |ServerLibPriv | |SystemInformation: Windows 10 (18363) x64 (AMD or Intel) Binary: 64bit
2020-03-17 09:19:07.478770|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2020-03-17 09:19:07.478770|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2020-03-17 09:19:07.478770|INFO |DatabaseQuery | |checking database integrity (may take a while)
2020-03-17 09:19:07.556899|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2020-03-17 09:19:07.572524|INFO |Accounting | |Licensing Information
2020-03-17 09:19:07.572524|INFO |Accounting | |licensed to : Anonymous
2020-03-17 09:19:07.572524|INFO |Accounting | |type : No License
2020-03-17 09:19:07.572524|INFO |Accounting | |starting date : Mon Jul 1 00:00:00 2019
2020-03-17 09:19:07.572524|INFO |Accounting | |ending date : Wed Jul 1 00:00:00 2020
2020-03-17 09:19:07.572524|INFO |Accounting | |max virtualservers: 1
2020-03-17 09:19:07.572524|INFO |Accounting | |max slots : 32
2020-03-17 09:19:07.713144|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
2020-03-17 09:19:10.463115|INFO | | |Puzzle precompute time: 2820
2020-03-17 09:19:10.463115|INFO |FileManager | |listening on, [::]:30033

The server try to start and in seconds it turns off.

Sorry for my english, and thanks a lot for your atenttion.

Please tell us your CPU.
CPU’s before 2009 and possibly around 2010-2011 miss required POPCNT.

You can try 3.12.0 Beta 3

1 Like

This solve my problem.

Thank you a lot.


Have you tried the 64 bit version of that beta or just the 32 bit version?