I cant start server 3.11.0 (CPU does not have POPCNT)

The 32 bit version of server 3.11.0 won’t change anything here.
Currently only server 3.10.2 or newer CPU will help then.

Will a later update fix it so I can use new server versions on the current CPU?

3.12.0 is said to support POPCNT only on x64 servers with x86 servers not needing it. But this version is in making right now so you need to use 3.10.2 for the time being.

Upcoming server 3.12.0 will allow you to use the 32 bit. The 64 bit variant won’t.


Can I dump the 64 bit server files in my 32 bit installation to update and keep my database? Or is that not possible.

It’s possible but you can not use the 64 bit specific files. We suggest to make a clean install and move needed files to the new installed server. Please read below.


Everybody in here now can try the 3.12.0.


Hey @TS.ChrisR,

i have the same Problem with the POPCNT. I found out that my CPU is to old and have not the POPCNT. I tried the 3.12 beta as 32bit version but still get this log informations

2020-02-25 14:00:10.839307|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.12.0-beta.1 (2020-02-19 09:45:27)
2020-02-25 14:00:10.839307|INFO |ServerLibPriv | |SystemInformation: Windows Server 2012 R2 (9600) x64 (AMD or Intel) Binary: 32bit
2020-02-25 14:00:10.839307|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2020-02-25 14:00:10.839307|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2020-02-25 14:00:10.839307|INFO |DatabaseQuery | |checking database integrity (may take a while)
2020-02-25 14:00:10.854933|INFO |SQL | |db_CreateTables() tables created
2020-02-25 14:00:10.886183|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2020-02-25 14:00:10.901807|INFO |Accounting | |Licensing Information
2020-02-25 14:00:10.901807|INFO |Accounting | |licensed to : Anonymous
2020-02-25 14:00:10.901807|INFO |Accounting | |type : No License
2020-02-25 14:00:10.901807|INFO |Accounting | |starting date : Mon Jul 1 00:00:00 2019
2020-02-25 14:00:10.901807|INFO |Accounting | |ending date : Wed Jul 1 00:00:00 2020
2020-02-25 14:00:10.901807|INFO |Accounting | |max virtualservers: 1
2020-02-25 14:00:10.901807|INFO |Accounting | |max slots : 32
2020-02-25 14:00:14.620566|INFO | | |Puzzle precompute time: 3681
2020-02-25 14:00:14.636191|INFO |FileManager | |listening on, [::]:30033
2020-02-25 14:00:14.636191|INFO |VirtualSvrMgr | |executing monthly interval
2020-02-25 14:00:14.636191|INFO |VirtualSvrMgr | |reset virtualserver traffic statistics

I run the Server on a WindowsServer 2012R2 machine with a PentuimE6600. If u need some more Informations feel free to ask :slight_smile:


PS: I tried it as new clean installtion and as imported in my old one

What are you referring to? We don’t see anything wrong in the log.

Btw. we just released beta 2 of 3.12.0 was just preparing the announcement thread.

1 Like

That’s not really true, my Xeon X3470 is from 3Q’09 and has Instruction Set Extensions: SSE4.2.
For those who have an “older” Intel CPU just have a look here Intel® Product Specifications.

Kind regards.

1 Like

I have EXACTLY your same problem. Solution?

have win 10 client installed, server will not install

1 Like

What do you mean by

in this case?

Please post some logs if you can and your PC specification. Without this no one can help you.


never got the server query, login password and token upon installation


I have no idea what this means or how to do it.

My guess is that he uses old hardware but does not tell us and the server will not start on that old CPU ;D
Try Server 3.12.0 [Beta]

OR he can not read that he has to accept the license.

Ps. there is no installer. You only extract the server package and start it.

1 Like

if the problem is the old hardware then he need to use the 32-bit version of 3.12.0 :stuck_out_tongue:
i think popcnt is not supported so… :smiley:
for 64 bit version still need popcnt supported hardware but no need for 32 bit version :slight_smile:

1 Like

HOW DO I do this?

DOWNGRADED SERVER version to -3.10.2 — works now!


Having a recent problem with my TS3 server crashing repeatedly on Windows Server 2008 Enterprise R2 x64. It has been working fine for years until just the other day. I can watch it crash repeatedly in the task manager. I use a program called firedaemon which runs it as a system service. It launches, maxes out the CPU for about 2 seconds, and then crashes. Repeat. It will create a 100 .dmp files in just a few minutes. The .dmp files don’t indicate location of the problem.

What I have done to trouble shoot:

I have updated the TS3 server to the latest version. Still crashing.
Copied the entire TS3 server folder to a different computer running windows 7 ult x64. The result is, the server runs properly. So it appears my TS3 server files are not corrupted. And that the problem lies with the TS3 server interaction with my Windows Server 2008 installation.

Any help would be appreciated.