Master password not accepted after restart (TS 3.5.1)


From the TeamSpeak 3 Client 3.5.0 [Beta] announcement thread:

And we fixed the bug where user with master password set in their client could not use their password any longer to encrypt the settings of their client. This bug only did exist in the old but already revoked version.

Apparently this has not been fixed properly, the bug still exists.

Operating system type and version: Ubuntu 18.04 LTS
TeamSpeak 3 Client version: 3.5.1

Steps to reproduce the faulty behavior:

  1. Make sure /home/USER/.ts3client is empty (BACK UP EVERYTHING INSIDE BEFORE DELETING!) so that a new profile will be created upon TS Client start.
  2. Start TS Client.
  3. A window displaying the license agreement will show up. Scroll down to the end, then accept.
  4. A window about myTeamSpeak features will show up. Click continue or quit.
  5. A window about myTeamSpeak login will show up. Do not login. Deselect “Stay logged in on this computer”, then click “Continue without login”.
  6. A window requesting for a username will show up. Type in anything you want, it does not matter.
  7. Now open the security settings: Go to “Tools” tab, then “Options”. In the window showing up click on “Security” on the left side.
  8. Select “Use a master password” and enter a short password (six characters are enough for this test).
  9. Close all windows clicking OK and shut down TS.
  10. Restart TS Client and enter the password you set before. TS won’t let you in.

Please fix this! If I had not created backups of my identities and settings before, everything would have been lost by now. Thanks!

EDIT: The bug even occurs when using an existing profile with a previously accepted master password. If you log out of myTeamSpeak in TS Client via settings and deselect “Stay logged in on this computer”, you’ll lock yourself out effectively. BE CAREFUL!

A post was merged into an existing topic: TeamSpeak 3 Client 3.5.1