myTeamSpeak ID is invalid (Dec 20/Jan 21)


Screenshot_2

I changed my password / recovery key, but can I still do the same?

1 Like

Same issue here.

check your firewall settings, make sure the correct ports are enabled

What more do I have to do?
I’ve tried on different servers but I keep getting an error. What exactly is the reason?

Same issue on Docker

stdout: 2021-01-02 06:45:24.854586|INFO    |VirtualServerBase|1  |rejecting myteamspeakid: revoke list out of date
stdout: 2021-01-02 06:45:24.854675|INFO    |VirtualServerBase|1  |client is connecting with a invalid or revoked myTeamSpeak ID
stdout: 2021-01-02 06:45:24.855103|INFO    |VirtualServerBase|1  |client connected 'yang'(id:3) from 172.17.0.1:47071
stdout: 2021-01-02 06:45:25.604851|INFO    |ServerLibPriv |   |failed to download revocation list - count: 1
stdout: 2021-01-02 06:45:28.026148|INFO    |VirtualServerBase|1  |rejecting myteamspeakid: revoke list out of date
stdout: 2021-01-02 06:45:28.026307|INFO    |VirtualServerBase|1  |failed to update myTeamSpeak ID

I don’t think I made a mistake in anything as a setup but
still the same I hope they offer a solution :slight_smile:

Sounds like there are problems with myTeamSpeak IDs?

This error reappears on my local server(Docker) and GCP , but join other servers did not have this problem

2 Likes

I still have the issue. Definitely an error of Teamspeak itself. I reset my whole server and it’s still not working. No blocking ports, no missing permissions.

1 Like

@Stefan92 I wonder if there will be news :frowning:

This looks like your servers fail to download the revocation list. This happens when the server can not access port 443 TCP outgoing.
Make sure that this is not blocked!

1 Like

what else do you need ?

My server also cannot download revocation list, but myTeamspeak is working. Probably because of it’s uptime.

Unfortunately I’m not able to understand Turkish but your screenshots look like 443 is part of your inbound rules, not outbound.

The ports opened for the TeamSpeak server are inbound rules of course.

Just make sure TeamSpeak is able to open a SSL connection to the TeamSpeak services.

2 Likes

This is actually more of a server issue than the client, so I guess continuing in this thread makes sense:

And yes, while this could be an issue with outgoing SSL-connections or invalid system time. This time it’s not. And it cannot be pure random chance, that this keeps occuring on this scale. I suspect it would be worse, if the revocation lists did not have a life time of about a month. So if they don’'t fix it, there should be a lot more complains around beginning next month, when all the servers that previously successfully downloaded the list have their copy expire.

One odd thing to add: While my server(s) cannot download the list. For me the client side warning only appears in the TS3 client and the mobile (iOS) one, but not on the TS5 beta client.

1 Like

While most people have this problem, I am sure that the problem is not caused by me alone, I think something should be done as soon as possible.

@Adam

This indeed is a server side problem! I tested with a clean server and also can not get the revocation list!
Adam is inactive though.
@TS.ChrisR @Cobra any ideas?

1 Like

My friend has the same problem with the newest version 3.13.3 (linux). Works fine before updating the server.

Can not reproduce this on my Server with version 3.13.3. Linux

twitch instagram twitter facebook