myTS services do not work (Badges &/or Twitch)

same as her brother

Hey, i love TeamSpeak, but can someone explain me why the users are not getting their ranks? twitch integration is activated and the users have their accounts connected but its not working :d

thanks for helping comments!

Hi, yesterday I changed myTeamSpeak password, I saved the recovery code, but after typing it into the client, all the settings came back except my badges (over 50!)

pls help :frowning:

Any update about this? I still doesn’t have my badge? :sneezing_face:

Hi everyone, we are currently experiencing some issues with myTeamSpeak as you can tell, which is causing your badges to not display and any other service that is associated with myTS to not work.

Please do not worry, nothing has actually been lost or removed from your account during this downtime. It is unfortunate that this problem occurs on the weekend, as we are not officially working during this time, so it may take until Monday to resolve the issue on our end.

We will fix the problem as soon as possible.

Thank you for your patience and we apologize for the inconvenience.


Continuing the discussion from How do I get a new recovery key? My Badges are not shown in client:

hello, so in teamspeak yesterday my teamspeak crashed. when i started it back up my teamspeak name had a 1 in it and all my badges are gone. any solution?

Me too, i have same problem with badges.
Yesterday i was on TeamSpeak 5 chatting with friend while playing one video game. After sometime we closed the game, said to each other “bye” and closed teamspeak.
Today i wanted to open TeamSpeak so we can pick where we left and there are no badges, not a snigle one. I had them yesterday but today, they are gone.
I tried with logout and login trick in hope that this is bug with TS5 since it is still in beta phase but no hope there. I opened Chrome browser to check myteamspeak account to see if there are badges and nothing.

I am waiting for the answer.

Have a look at this thread:

Just Wait for the Fix tomorrow

moved by moderator


I had to reset my password and don’t remember my recovery key. When I try and do the fallback to get a new recovery key, it’s telling me that the fallback fails.

Then in the client log it says:

9/5/2022 03:30:15		Info	TeamSpeak Client 3.5.6 (2020-11-25 13:53:42)	
9/5/2022 03:30:15		Info	SystemInformation: Windows 10 (22000) x64 (AMD or Intel) Binary: 64bit	
9/5/2022 03:30:15		Info	Using hardware aes	
9/5/2022 03:30:15	Direct Sound	Debug	setting timer resolution to 1ms - 	
9/5/2022 03:30:15	ClientUI	Info	OpenGL Info: LibGLES, Vendor: Google Inc., Renderer: ANGLE (Intel(R) Iris(R) Xe Graphics Direct3D11 vs_5_0 ps_5_0), Version: OpenGL ES 2.0 (ANGLE	
9/5/2022 03:30:15	Addons	Info	Checking for addon updates...	
9/5/2022 03:30:15	Plugins	Info	Loading plugin: clientquery_plugin_win64.dll	
9/5/2022 03:30:15	Query	Info	listening on	
9/5/2022 03:30:15	Plugins	Info	Loading plugin: teamspeak_control_plugin_win64.dll	
9/5/2022 03:30:15	ControlPlugin	Info	Control Plugin started, accepting connections	
9/5/2022 03:30:15	Plugins	Info	Loading plugin: gamepad_joystick_win64.dll	
9/5/2022 03:30:15	Gamepad Plugin	Info	Found client raw input wnd proc	
9/5/2022 03:30:15	Gamepad Plugin	Info	Cleared device list	
9/5/2022 03:30:15	Gamepad Plugin	Info	Found device \\?\HID#VID_046D&PID_C539&MI_02&COL03#7&329F78A&0&0002#{4D1E55B2-F16F-11CF-88CB-001111000030}	
9/5/2022 03:30:15	Gamepad Plugin	Info	Found device 	
9/5/2022 03:30:15	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList	
9/5/2022 03:30:15	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList	
9/5/2022 03:30:15	Addon	Info	Addon up to date.	
9/5/2022 03:30:15	Addon	Info	Addon up to date.	
9/5/2022 03:30:15		Info	*** Time [BUILD_GUI]: 370	
9/5/2022 03:30:15		Info	*** Time [SERVERVIEW]: 389	
9/5/2022 03:30:15		Info	*** Time [SERVERVIEWMANAGER]: 404	
9/5/2022 03:30:15	Addon	Info	Addon up to date.	
9/5/2022 03:30:15		Info	*** Time [MAINWINDOW]: 829	
9/5/2022 03:30:15		Info	*** Time [INIT]: 830	
9/5/2022 03:30:15	ClientUI	Info	Qt version: 5.12.3	
9/5/2022 03:30:15	ClientUI	Info	Using configuration location: D:/TeamSpeak 3 Client/config/settings.db	
9/5/2022 03:30:16		Info	current mytsid data is invalid - blocked to request new	
9/5/2022 03:30:16	ClientUI	Info	Last update check was: Sun Sep 4 21:24:35 2022	
9/5/2022 03:30:16		Info	Statistics report: Not yet, next report on Thu Sep 15 21:48:52 2022	
9/5/2022 03:30:16	Bookmarks	Info	Collecting autoconnect bookmarks	
9/5/2022 03:30:16	Newsticker	Info	Newsticker next check: Tue Sep 6 02:24:37 2022 GMT	
9/5/2022 03:30:26	ProtobufRPC	Warning	Error contacting URL TIMEOUT	
9/5/2022 03:30:36	ProtobufRPC	Warning	Error contacting URL TIMEOUT

I have tried disabling firewalls (it’s added as an exception anyways) and that doesn’t fix anything.

Any assistance would be greatly appreciated!

moved by moderator

Hello, trying to change my password without succeed I had to use the “reset password” option.
The system let me know that I needed my recovery key (ok, I have it stored since years ago), but at the moment of use it, it didn’t work!
Thinking that I can recover my accesses doing it manually and asking again to the servers’ masters for permissions, I tried to use the option “Alternative Option” (Deleting all) but again without succeed.
Since hours ago I’m trying desperate to request a new recovery key or to make the procedure called as “Fallback”, but not any explanation typed in the FAQ or posted in the forum are working.
Anyone could help me to solve this problem?, at least even losing my data I’d like to recover my account synchronization feature.

The issues related to the myTeamSpeak services got fixed.

Badges, Twitch, Recovery key or Fallback should work again.


Doesn’t work for me again. :neutral_face:


Fixed :+1:


Thanks for fixing this Problem. :slight_smile:

It was fixed, but now I am facing the same issue and it broke again.

Doesn’t work for me!

It seems the myTeamSpeak Service are not working correctly at the moment. I am facing the same issue.

Yup i confirm, MyTS got again the problem

The Issue seems to be fixed again. :slight_smile:

For me is the myTeamSpeak Service working