TS3 on Android completely non-functional

The Android version of TS3, running on Android 13, doesn’t work at all anymore. It will launch, but it cannot connect to any server. It just gets stuck in an infinite loop of “trying to connect” with no errors or timeouts, but never connecting. Enabling logs doesn’t seem to spit out a log file anywhere.

Looks fine and normal on 3 devices (Android 12, 13 & 14) here.
Tried a domain and IP and servee nickname.

You may try to reinstall the app.


I have reinstalled SEVEN TIMES already. Does completely jack. I can’t even connect to the default public TeamSpeak server.

I have no idea why this won’t work on your device.
Guess it worked before because you wrote anymore?

Have you accepted all permissions which get asked on first start? Please check the app permissions on Android afterwards.

Do you have a identity which is set as default? Maybe this could cause this state.
You can check it in the Second Item on top. There should be at least on identity and marked with a blue greyish color.

Please try without logging in after reinstall. Maybe something in your account is broken.

1 Like

Google Playstore shows on web (chrome) newest update from 10.2023.
On my friends Android tabled and also my own )2 year old Samsung galaxy tablet), it shows a newest version from 2016, which I think is a pretty big bug here.
Also my tablet wanted to downgrade from version 3.4.3 to this non functional 2016 version.
3.4.3 works fine and is able to connect to all servers.
This outdated 2016 version can‘t connect to any server.

@TS.ChrisR Please check your google playstore app settings in which cases it only shows a 2016 version for some devices/scenarious? Looking at this versions reviews, many many comments experience the same bug.

Opening the same app on chrome indeed shows the newest version, so I think it’s some bug by the set Android version or device settings.

1 Like

That’s a good point.
The Playstore on Android itself shows and loads this ancient version. Even with remote install.
Thanks for that hint.

I guess Google changed some rules and just applied these. Forwarded this issue.

Meanwhile: You can download this APK (It’s the latest published version just extracted from my device).
App should work fine as long Google Playstore is installed and can check that account owns the application.


Ps downgrading any app on a non modified Android is not possible without uninstall.
So I can’t believe this part :stuck_out_tongue:


I’ll install that and report back.

EDIT: Nope. Still infinite “Connecting…” dialog. No matter what server I select. All servers are up-to-date, and like I said, I can’t even connect to the public one. On PC, it works, so it’s not my network. On my phone, I can’t connect either through Wifi or Data, no matter where I am.

Currently using an Ulefone Armor 24. No idea if that helps any.

And yes, all permissions are set, and ID is synchronized and set to default.

It just doesn’t work.

I have noticed the app doesn’t require storage permissions (it doesn’t ask or list any in the app settings), could that be why I can’t get a log made, or why the TS3 folder on the SD root doesn’t generate like it used to?

Does the app i linked show a copyright of 2022 on start and icon looks similar to my avatar?
In that case it is the latest version and should work fine.

The version you get from Play Store is old.
The night i had 2 devices giving me the old version. But now only one device is left.

Can you tell me your Play Store version? Following is just for information.
Do not touch your Play Store or else you may brick the app and won’t be able to recover it.

On Play Store version 39.2.37-29 [0] [PR] 597374538 I get the latest client.
While on newer version 39.2.38-29 [0] [PR] 597395080 I get old client.

At this point we have no idea why this is happening. Maybe some routing, bucket, space etc. on Google broke or newer Play Store has a bug.

1 Like

I see version 3.4.4.

This is the latest version and should work fine.
I tested that on the device where I also get the old version 3.0.2x trough Play Store.

And what Play Store version does your device actually have?

1 Like

If you have no idea what’s happening on the google side, it’s maybe worth a try to publish a „3.4.5“ version as an update to the Playstore. Maybe it fixes the bugged Playstore version. Would be a probably faster fix in this case than trying to contact google.

For me, I can confirm installing the newest apk works.

@StrikerTheHedgefox you can check your DNS settings on your phone.
Try setting google DNS

In case your DNS setting fails to resolve domains.

This was on our mind but would also mean to kick out old Android devices because for this case we must raise the needed API.

Actually we support 4.2.2. up to Android 14.
This is our last option to do this step.

Simply releasing an new version may not help. It’s not all devices or Play Stores (we do not know why and how this is related) get a version now that is 7-8 years old.

1 Like

@TS.ChrisR I understand the problematic.
You can also try to edit something in the description, without changing the uploaded app.
Maybe this triggers something at google to get them back all to the current versions.

I tried force stopping the Playstore, cleared cache and cleared data. Restarted the device. It still loads the 2016 store version. As far as I can see, it’s not a device cache issue. Maybe a google server cache issue.

My Playstore version is:
39.2.37-29 [0] [PR] 597374538

Setting the DNS made no difference. Nothing about my network is wrong.

My play store is 39.3.33-29 [0] [PR] 599690833

@Crypto90 @StrikerTheHedgefox

We have submitted a new version to the PlayStore.
This may take some time until it is activated.

This aApp version 3.4.5 should fix the issue.
It seems that devices without hardware telephony where effected to this change.

Thank you both for reporting this issue!


The PlayStore now offers the update.

Feedback would be nice.

1 Like

It’s downloaded, but I still can’t connect to any server. Still getting the perpetual spinner & “trying to connect”. In my case, I’m not on a tablet, I’m on a phone. It has hardware telephony. I wasn’t getting an old version on the store like the other guy, either.

If a blank app start without logged in to myTS doesn’t work and 3.4.4 & 3.4.5 doesn’t connect for you and any other of the mentioned doesn’t…

…then I’m out ideas.


I’m literally connecting through a bookmark that’s synchronized with MyTS, and I can connect on all other platforms except on Android.

Have you tried without logging in into myTS?
Asking because mentioned it twice but had no feedback and now you wrote you login to myTS before.

1 Like