Unable to find default serveradmin account TeamSpeak 3 Server 3.13.1

2020-11-17 05:41:22.541818|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.1 (2020-11-11 09:54:16)
2020-11-17 05:41:22.542793|INFO |ServerLibPriv | |SystemInformation: Windows Server 2016 (17763) x64 (AMD or Intel) Binary: 64bit
2020-11-17 05:41:22.542793|INFO |ServerLibPriv | |Using hardware aes
2020-11-17 05:41:22.543770|INFO |DatabaseQuery | |dbPlugin name: MariaDB plugin, version 3, ©TeamSpeak Systems GmbH
2020-11-17 05:41:22.543770|INFO |DatabaseQuery | |dbPlugin version: 2
2020-11-17 05:41:22.608188|INFO |SQL | |database updated successfully to revision: 34
2020-11-17 05:41:22.615016|CRITICAL|ServerLibPriv | |unable to find default serveradmin account

Version 3.12.1 works fine :frowning: , i need help
i cant not update sry for my bad english

Without the database we can only repeat what the error says.

The serveradmin account with client_unique_id serveradmin does not exist on server_id 0.
In that case the database looks modified or the account was deleted (both happened in the past already).

2 Likes

I did have the same issue with the .13.x update on an otherwise unmodified database.
In the past you would not get any support from TeamSpeak regarding fixing database issues.
And I do remember posts being deleted that suggested otherwise. So I will only mention that you should check that nickname, login name and other naming fields are “serveradmin” for the serveradmin account.
Otherwise 13.x will not start. I did submit a ticket about this issue. This had never happened before. ¯\_(ツ)_/¯. Would at least suggest the code looking for the client does not rely completely on the ids anymore or there were additional checks added.

Could it bet that the database is really really old? I may have an idea why some users have this while others do not have the problem.

Yes this check is new. We are helping if it’s our fault.

1 Like

I do have an older sql dump from the server database. I just looked into the virtualserver_created value and it is: 19.12.2009. So yes. A bit older :slight_smile:.
But as I stated earlier I already fixed the issue after creating a backup. Question is if @alex91 issue is related/same.

I guess his db is also older than 2016.

2 Likes

wow thanks for many answer , and thanks for help.
Im checkingup but icant with older version dont changed serveradminquarry nothing im login bot i cant not changed :confused:

Nothing works , i have changed again old version works fine machine_id and server_id is on 1 (ts3server.ini) and serveradmin under clients tabel is 1 by server_id :confused:

In your database this red marked part is the same?
grafik

1 Like

We plan to release a new version where this issue is still logged but server won’t stop.

An update was released

3 Likes

no my server have machine_id 1 and all row called 1.

I have changed and he make a new superadmin quarry , server started and works fine .
Im changed superadmin password manuell the superadmin password is blank but this is not so dangerous. And i have a API WoW :smiley:
Chris big thanks my Server works fine under (changed id) workaround .
You can cloesed this Thread.
Thanks Teamspeak Community ^^

twitch instagram twitter facebook