Wrong Flag on all Teamspeak Servers!

Make sure server is up-to-date with the latest geolocation database.

So for my client, my country flag isn’t showing on Teamspeak and hasn’t done for several months. The teamspeak server is running the latest 3.13.3 but no changes. I’ve checked the website where teamspeak gets country flags from and it returns United Kingdom. Is there anyway to fix this issue?

2 Likes

Did you activate the setting to view them?
if not, go to
Tools > Options > Design
and check the ‘display country flag on clients’ box

I can see everyone else has a country flag, just not me. I researched into it and it’s something about the way the teamspeak server grabs the country using everyone’s IP, maybe the database hasn’t been included to use mine?

If it’s a local connection you will not see it.
If you do not see it while connected to an external IP (nothing in your LAN/WAN) then the IP is not known in servers ip2location database.

Option 1 is to wait for next server update or Option 2 is to ask the host to use a Maxmind database (see server changelog).

3 Likes

Hi,

Sorry for the delayed response. It still shows no flag when connected to any public TeamSpeak server running the latest version (3.13.3). On the ip2location database, my IP shows up as the United Kingdom and has done for a couple of months now. Will this be fixed?

As said

2 Likes

Hi again,

So I see 3.13.5 was released, great! I joined several public servers running 3.13.5, but it still doesn’t know what country I’m from. I have waited for the server update, but no change. The IP2Location database has my IP down as United Kingdom, so why hasn’t it updated in the latest update? My location has been on that website for many months now.

This is an process that happens automatically before a server was build.
So i assume this db was updated.

But i forward that to our developers to make sure if an update was applied.

3 Likes

Heya

From 3.1.1 Linux to 3.13.5 Linux dont fixed the wrong flag

inetnum: 5.252.179.0 - 5.252.179.255
geoloc: 55.652641 37.529029
country: RU
City Moscow
Coordinates of City 55.752220, 37.615560 (55°45’8"N 37°36’56"E)
IDD & Area Code (7) 0495

i get a Moldova flag, dunno why

on https://www.ip2location.com/demo all fine the flag with RU ( [Russian Federation]
Country information about Russian Federation [RU]
i hope u can fixed or can you give an instruction how to use the GeoIP from MAX, what exactly you have to do, e.g. which DB etc.?
cya
Xenya

Please take a Look here

i read that, did you also read my text ? :slight_smile:
from 3.1.1 Linux to 3.13.5 Linux server version it was not fixed, and I think that’s quite a few versions in between or ? :slight_smile:
TeamSpeak 3 3.1.1.1 released on January 15th, 2020 and TS3 Server 3.13.5 on 18 May 2021

Also since server release 3.13.0 9 November 2020
this is supported: New support for MMDB style GeoIP databases
But there is no exact instruction how to do this or which DB to use from MMDB.
cya
Xernya

Quoting the server_quickstart.md which can be foudn in the doc folder

  • mmdbpath (empty)
    Set to the path of an MMDB file to use this as a source for GeoIP lookups. Requires libmaxminddb installed, which can be found in most Linux distributions as a package. Windows users can use the .dll found in the redist folder.
1 Like

Heya
no i mean which DB, csv etc ( country, city )
cya
Xenya

The DB you downloaded from MaxMind.
You can use all their DB types.

1 Like

Heya
ok i wanna try this on the ts3.ini file with mmdbpath=geoip/geo.mmdb
from GeoLite2-Country_20210601
cya
Xenya

1 Like

Heya

works perfect with this DB, all fine now
start the server with ./ts3server_startscript.sh start inifile=ts3server.ini
logfile: 2021-06-07 13:13:36.632316|INFO |GeoIP | |mmdb database found and will be used for geoip lookups

cya
Xenya

1 Like

2 posts were split to a new topic: IP2location database is outdated with latest server

Hi, I need some help, a flag of my country doesn’t appear next to my name on TS3, could someone help me, I’ve already been banned because of that I would like to solve

Sometimes there are gaps in the geo-location data. Are you using a VPN ore somethins witch blocks you geo-location? I had that same problem once and a serverupdate fixed it for me.

Do you have this porblem on every teamspeak server ore just one?

And just a tip this is an englisch forum so please you englisch next time :smiley:

twitch instagram twitter facebook