Badges don't work

Hi everyone, last time I don’t see my badges in the “badge settings” but I have them on TeamSpeak website(dashboard). Does anyone have the same problem?If so, then please tell me how to fix it.

Have you tried logging in again?

yep

Check for the following criteria to see your badges:

  • Make sure that you are connected (network/internet)
  • Logged in on myTeamSpeak
  • Send your myTeamSpeak ID before connecting to a server (check https://i.imgur.com/SDQgvt2.png)
  • Own the latest client version: +3.3.0
  • Stay on a server with the latest version: +3.9.1 (for the best reason)
  • Having your badges enabled
  • Make sure that your cache folder is not empty or destroyed
    (windows: C:\Users\USERNAME\AppData\Roaming\TS3Client\cache\ badges)
    (open %appdata%/TS3Client)
  • Make sure that the synchronization is enabled (press Alt+P > Go to myTeamSpeak)
1 Like
  1. I’m connected
  2. I’m logged
  3. I always send myTeamSpeak ID
  4. 3.5.2
  5. server version is +3.9.1
  6. where enabled? I wrote a code and I had this badges in “badges settings”
  7. I have that folder
  8. enabled

Probably I lost badges when I changed myTeamSpeak password but when I write Rocket Beans badge code, says I already have the badge.

So you’ve changed myTS password?

Then you need to use Recovery Key to be able to use badges once more. Few people here had this issue in few past days and the answer was always the same, Recovery Key.

See here:


1 Like

it worked thanks!

Am si eu aceeasi problema. Am inteles ca se rezolva prin cheia de recuperare, primita cand am schimbat parola. Daca nu am cheia de recuperare … cum pot remedia aceasta problema?

A post was merged into an existing topic: How do I get a new recovery key? My Badges are not shown in client

twitch instagram twitter facebook