Can not start my server (max slot limit reached)

Touching the database directly is not supported.
There is always a risk to destroy it.

1 Like

after I had no other choice since the server did not want to start the only solution was to open the file and just modify 64 slots into 32 slots in itself I did not modify anything big

You just could have logged via ServerQuery as Fake mentioned and gave an how to and change the slots.
It’s not needed that the voice server started.

The use 1 -virtual as an example allows to select the voice server as long the server instance is running.
Then you could’ve performed command serveredit virtualserver_maxclients=32 followdy by serverstart sid=1

Threads merged


So as i said in the title, i can’t run my teamspeak3 server because server properties have 128 slots, my license expired, i deleted licensekey.dat from the folder.

I work on dedicated windows server.
I have many IP address, so i set ts3server.ini with the IP i want to work with ts3.

Please help me.

I want to run back to 32 slots, i don’t need a license anymore, but my server is off so i can’t modify 128 slots, and put back to 32 slots. I don’t need help about an expired license. I need help to run my server and put back the 32 slots…

moved by moderator

I update my TS3 server exactly with instruction here Update / Upgrade a TS3 server after all, server start and running but can’t connect with them. When I remove my ts3server.sqlitedb and then start server I connect with them without any problem. What could go wrong? What to do to restore my server settings?

Can you share your server log and your Client Log pls? :slight_smile:

It look like license problem. I have free license for 512 o 1024 slots (don’t remember) for non commercial. How can I get back to work my server?

I don’t have ts3server.ini (or I can’t locate it) and licensekey.dat are exist and is empty. I read that I probably can’t recreate licensekey.dat for non profit old free license (I have my serar I think almost 10 years) I even don’t remember how I got it, is it possible that I have it on e-mail? I do some backups in this years but only ts3server.sqlitedb.

If is not possible to get back my license key file then is it possiblilty to edit ts3server.sqlitedb to get back server settings, users?

You edit the server with Server query to reduce the slots.


I have an issue, I had a license that expired after 1 year and my server died, I had an issue that i didn’t know it’s a license issue and i reinstalled my VPS but I had a backup anyways of the teamspeak.

Now when I run the new teamspeak server it works, but when I try to backup the old server it still doesn’t work even tho I don’t include licensekey.dat in the backup.

I tried to backup only (ts3server.sqlitedb) and it doesn’t work and the server doesn’t connect, if i restore it to the new server (ts3server.sqlitedb) works fine.

Anyone can help me understand why this is happening and how to get back my old server? I have the full folder backed up.

Most likely you increased the slot limit so without a vid license the virtual server won’t start. The log files should tell you more though.
As long as the server itself starts you can connect to the query and decrease the slot limit again.


yes the server starts,

how do i connect to the query and do that? I’ve never done that before and what are the needed tools

Probably the simplest GUI query program is YaTQA.
If you directly want to use Telnet, then I recommend you to download PuTTY, assuming you are on Windows, and to follow this amazing guide.

1 Like

After doing everything you said and I connected with telnet to the query, I found out that the max slots is set to 32 and not like you said, since I haven’t edited it manually.

so issue still exist and I’m not sure why…


Are you sure you checked the right server and not the template?

What is the server log telling you about the license part.


This is when I check on the systemctl status:

How to check on the log itself?

systemctl status teamspeak -l

  • teamspeak.service - TeamSpeak3 Server
    Loaded: loaded (/etc/systemd/system/teamspeak.service; enabled; vendor preset: disabled)
    Active: active (running) since Tue 2022-04-19 09:27:18 UTC; 26s ago
    Process: 703 ExecStop=/opt/ts3server/ stop (code=exited, status=0/SUCCESS)
    Process: 716 ExecStart=/opt/ts3server/ start (code=exited, status=0/SUCCESS)
    Main PID: 723 (ts3server)
    CGroup: /system.slice/teamspeak.service
    `-723 ./ts3server daemon=1

Apr 19 09:27:18 servername systemd[1]: Stopped TeamSpeak3 Server.
Apr 19 09:27:18 servername systemd[1]: Starting TeamSpeak3 Server…
Apr 19 09:27:18 servername systemd[1]: Started TeamSpeak3 Server.
Apr 18 09:03:23 servername[11107]: found, but no server running. Possibly your previously started server crashed
Apr 18 09:03:25 servername[11151]: Starting the TeamSpeak 3 server
Apr 18 09:03:27 servername[11193]: Starting the TeamSpeak 3 server
Apr 18 09:03:29 servername[11234]: Starting the TeamSpeak 3 server
Apr 18 09:03:31 servername[11275]: Starting the TeamSpeak 3 server
Apr 19 08:49:10 servername[6406]: Starting the TeamSpeak 3 server

I think this is what you’re looking for:

2022-04-19 09:27:18.799813|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.6 (2021-06-09 10:22:37)
2022-04-19 09:27:18.822347|INFO |ServerLibPriv | |SystemInformation: Linux 4.9.0 #1 SMP Thu Apr 22 16:18:59 MSK 2021 x86_64 Binary: 64bit
2022-04-19 09:27:18.822386|WARNING |ServerLibPriv | |The system locale is set to “C” this can cause unexpected behavior. We advice you to repair your locale!
2022-04-19 09:27:18.822411|INFO |ServerLibPriv | |Using hardware aes
2022-04-19 09:27:18.823360|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
2022-04-19 09:27:18.823409|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2022-04-19 09:27:18.823683|INFO |DatabaseQuery | |checking database integrity (may take a while)
2022-04-19 09:27:18.900514|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2022-04-19 09:27:18.900668|INFO |Accounting | |Licensing Information
2022-04-19 09:27:18.900692|INFO |Accounting | |licensed to : Anonymous
2022-04-19 09:27:18.900709|INFO |Accounting | |type : No License
2022-04-19 09:27:18.900731|INFO |Accounting | |starting date : Thu Oct 1 00:00:00 2020
2022-04-19 09:27:18.900748|INFO |Accounting | |ending date : Tue Nov 1 00:00:00 2022
2022-04-19 09:27:18.900763|INFO |Accounting | |max virtualservers: 1
2022-04-19 09:27:18.900777|INFO |Accounting | |max slots : 32
2022-04-19 09:27:20.229955|INFO | | |Puzzle precompute time: 1305
2022-04-19 09:27:20.230353|INFO |FileManager | |listening on, [::]:30033
2022-04-19 09:27:20.243041|INFO |Query | |Using a query thread pool size of 2
2022-04-19 09:27:20.316803|ERROR |VirtualSvrMgr | |loading VirtualServer(1) failed to start, error: max slot limit reached
2022-04-19 09:27:20.317177|INFO |Query | |listening for query on, [::]:10011
2022-04-19 09:27:20.317478|INFO |Query | |listening for ssh query on, [::]:10022
2022-04-19 09:27:20.317629|INFO |Query | |listening for http query on, [::]:10080
2022-04-19 09:27:20.317740|INFO |CIDRManager | |updated query_ip_allowlist ips:, ::1/128,

How does it say max limit reached when on the query it says 32 slots

Edit: I used YATQA and I had to start the server virtually and edit the max slots back to 32 and it worked, but I still wanna understand why this happened and how come when I connected to the query it still said 32

In that case server with ID 1 tried to start with more than 32 slots.
You said the server has 32 slots set but this can not be when the message above appears.

Make sure you did set the right slots and not just the reserved slots as an example.


I encountered a weird problem, tried to look for a place to open a support ticket, but couldn’t find it, so hope someone will be able to help me here. I’m hosting my own TS for a while and during the current license renewal phase I switched to a license with less slots (64 slots).

I configured the virtualserver according to the new slot amount:

serveradmin> serverinfo
virtualserver_unique_identifier virtualserver_name=[edited]

But for whatever reason, the server fails to start. According to the logfile:

2023-05-19 19:29:36.396401|INFO |Accounting | |Licensing Information
2023-05-19 19:29:36.396450|INFO |Accounting | |licensed to : [edited]
2023-05-19 19:29:36.396467|INFO |Accounting | |type : Activation License
2023-05-19 19:29:36.396489|INFO |Accounting | |starting date : Wed May 17 00:00:00 2023
2023-05-19 19:29:36.396505|INFO |Accounting | |ending date : Fri May 17 00:00:00 2024
2023-05-19 19:29:36.396520|INFO |Accounting | |max virtualservers: 1
2023-05-19 19:29:36.396534|INFO |Accounting | |max slots : 64
2023-05-19 19:29:36.995521|INFO | | |Puzzle precompute time: 574
2023-05-19 19:29:36.995895|INFO |FileManager | |listening on, [::]:30033
2023-05-19 19:29:36.998060|INFO |Query | |Using a query thread pool size of 2
2023-05-19 19:29:37.038831|ERROR |VirtualSvrMgr | |loading VirtualServer(1) failed to start, error: max slot limit reached

All ideas / hints are appreciated!

Hello @kbarny23.

Maybe you will find the Solution in this Thread: