Free Teamspeak - Can not modify permissions

when I connect to the server with a TS3 client and then call the permissions system, I can see the permissions but cannot change them. This is not possible because of the Groupe modify power, which is not set. Is this intentional because of the free server or will it be changed when the permissions system is integrated in Teamspeak 5?

1 Like

On the Social Media Webpage. I saw a Post about the TeamSpeak 5 Permission System. The Release is probably next Week. :slight_smile:


That would be awesome. :nerd_face:

1 Like

The permission system is now integrated but you can’t do anything because you have no group modify power.
Did I have to conntect the support?
What can I do?

They’re intentionally not that editable for the free servers right now.


Will Teamspeak change that in the near future?
Or will it always stay that way because they are free servers?

so yep it will change :smiley:

Please don’t spread false information just from words used by staff.
They only describe the current permission setup on these free servers.


Will permission to edit / add authorization to the TeamSpeak 5 free server?

oh okay, I got it, I could misunderstand something.

We can not tell if permissions will change in a way where user can do more with groups on these servers. It’s just hard to choose words where nobody else could interpret something else then said :slight_smile:

Topic is on the table for discussion but nothing more.


When will paid servers be added?

Hey TeamSpeak staff and com,

I tried to modify the “Serveradmin” & “Member” groups and had to find out, that I’m not
able to change any permissions on subordinated servergroups. I myself got the “Serverowner” group and normally should be able to make changes on servergroups below “Serverowner”. I tried to change many different permissions and couldn’t change any of them.

On the screenshot’s i made you can see an example for what i wanted to change.

So i got the option to see the permissionlist for the groups on my TeamSpeak hosted
server, but can’t modify any of it?!
Does anybody know how to fix this or is that what TeamSpeak wanted?
I’m slightly confused as you can tell :sweat_smile:

Thanks for your reply, yet !

I’m not 100% sure, but I think you can’t and should not be able to change any permissions on the free server, someone please correct me If I’m wrong here.


Yes this is mostly correct.
At the moment it is intended that almost all permissions are not modifiable on the free server.
This includes all group permissions.
Most (if not all) channel permissions are modifiable.

1 Like

Good night!

Fortunately, I have access to the TeamSpeak 5 beta, I created my free server to play with friends, however, I have no permission to create groups, edit channels, create permanent rooms, etc.

Is this for all users or am I just in trouble?

Permissions are way too hard disabled on free servers as far I know.


Hello, i’m a beta user of ts5 and i have a problem with ts5 free server since I don’t really understand how permissions work.
So basically I want to edit perms such as channel modify power (75 to 999 for example) but I can’t since it says I don’t have the permission i_group_modify_power (
Something I have to say is that I might messed up with permissions when I got my 10 slot server, and I don’t know how to fix it or how to delete and recreate the free server. Hope you can help me. Thanks

All good. It is intended that you can not edit the permissions of the free server.

Can we get more customization for our free ts5 servers? Like setting avatars and in general admin rights?