Teamspeak 3 Crashes Instantly Upon Being Open On MacOS 10.13.6

Around 2 days ago, I tried downloading the Sonoran Radio plugin on Teamspeak for a community I was in and it seemed to be going well, downloaded fine, until it asked me to restart the TS3 app. I quit the app and tried re-opening it. It closed immediately after 10 seconds of the app being open. I tried again, same thing, this then started me on a 12 hour journey to fix it with no results. I tried downloading it, purging all files related to teamspeak from my PC, downloading the 3.5.7 beta which still didn’t work. Downoading the 5.0.0 Beta which somehow worked for a day, but then I came back and it stopped working due to my version not being compatible for some reason, and I’ve done basically everything I can think of. The main issue is that whenever I try to launch the TS app, it immediately closes. Unlike other bugs, my Teamspeak literally just instantly closes when just trying to open the app, not connecting to a server or anything like that. If anyone knows how to fix this, please do help, thanks lol.

Also to elaborate, my Mac is rather old, so no, it cannot update past 10.13.6, and before this Teamspeak worked perfectly fine.

1 Like

Please try this to fix the Crash:

Could you try elaborating? I dont understand where I change into the “Beta Channel”?..

Have a look at this post. No need to read the whole thread, I quoted the important part.

I see, I would do that but the thing is the app closes literally as soon as I open it, I’ll see if I can get a video

twitch instagram twitter facebook