TS client crashes on MacOS when connecting

Trying to open up a server on my TeamSpeak, I only have TeamSpeak as its required to participate in certain aspects of my hobby. Every attempt I make to connect to a server, the application closes with no crash report or error afterwards. Need assistance

Try this Version out: http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/TeamSpeak3-Client-macosx-3.5.7.dmg

thank you, will do

Worked, thank you for the help with that. I was wondering if I had to update it or not, now I know. For future reference, do I update the launcher through the application or the website?

If there is a new update in the Client available update it there. The next update should fix the crashes

Hi, I have a problem with Ts3:
Every time I want to connect to a server (any server) TS crashes without any error code, just like when I activate the language test. Otherwise everything works, options etc. The teamspeak client crashes upon trying to open an input device. No error messages or anything. It just crashes silently.

Thanks if someone can help me.

To fix this, please Download this Client: http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/TeamSpeak3-Client-macosx-3.5.7.dmg

Hi, I can’t join any server. After I press connect, it automatically closes right after. I already tried to reinstall it. Please help me

Im on Mac newest version , reinstalled already, no plugins except the automatic one installed

This Version fixes the crash: http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/TeamSpeak3-Client-macosx-3.5.7.dmg

Hello. Please solve my problem. MacOS. TeamSpeak client automatically turn off when I connect to any server. Thank you!

You may need this:

Last login: Mon May 10 12:40:58 on ttys000
/Applications/TeamSpeak\ 3\ Client.app/Contents/MacOS/ts3client_mac ; exit;
maciejkunat@MacBook-Air-Maciej ~ % /Applications/TeamSpeak\ 3\ Client.app/Contents/MacOS/ts3client_mac ; exit;
Crashdump ENABLED, directory is: /Users/maciejkunat/Library/Application Support/TeamSpeak 3/crashdumps
DUMP defined! Dumpdir is: /Users/maciejkunat/Library/Application Support/TeamSpeak 3/crashdumps
2021-05-10 10:41:56.070412|INFO | | |TeamSpeak Client 3.5.6 (2020-11-25 13:53:42)
2021-05-10 10:41:56.070522|INFO | | |SystemInformation: Darwin 20.4.0 Darwin Kernel Version 20.4.0: Thu Apr 22 21:46:47 PDT 2021; root:xnu-7195.101.2~1/RELEASE_X86_64 x86_64 Binary: 64bit
2021-05-10 10:41:56.157672|INFO |ClientUI | |OpenGL Info: LibGL, Vendor: Intel Inc., Renderer: Intel(R) HD Graphics 6000, Version: 2.1 INTEL-16.2.16
2021-05-10 10:41:56.158505|ERROR |RevocationListCache| |Failed to import revocation list from cache
2021-05-10 10:41:56.285464|INFO | | |*** Time [ICONMANGER]: 141
2021-05-10 10:41:56.286493|INFO |Addons | |Checking for addon updates…
2021-05-10 10:41:56.321132|INFO | | |successfully downloaded revocation list for accounting
2021-05-10 10:41:56.351430|INFO |Plugins | |Loading plugin: libclientquery_plugin_mac.dylib
2021-05-10 10:41:56.387064|INFO |Query | |listening on
2021-05-10 10:41:56.443406|INFO |Addon | |Addon up to date.
2021-05-10 10:41:56.474209|INFO | | |successfully downloaded revocation list for myteamspeak id
ClientQueryPlugin: currentServerConnectionChanged 1 (0)
2021-05-10 10:41:56.598126|INFO | | |*** Time [MAINWINDOW]: 512
2021-05-10 10:41:56.598273|INFO | | |*** Time [INIT]: 512
2021-05-10 10:41:56.964694|INFO |ClientUI | |Qt version: 5.12.3
2021-05-10 10:41:56.964809|INFO |ClientUI | |Using configuration location: /Users/maciejkunat/Library/Application Support/TeamSpeak 3/settings.db
2021-05-10 10:41:57.207133|INFO |Bookmarks | |Collecting autoconnect bookmarks
2021-05-10 10:41:57.208719|INFO |ClientUI | |Last update check was: pon. maj 10 12:24:12 2021
2021-05-10 10:41:57.209373|INFO | | |Statistics report: Not yet, next report on czw. cze 3 12:34:20 2021
2021-05-10 10:41:57.601879|INFO |Newsticker | |Newsticker next check: wt. maj 11 10:24:14 2021 GMT
2021-05-10 10:42:05.066053|INFO |ClientUI |1 |Connect to server: voice.teamspeak.com
2021-05-10 10:42:05.069743|INFO |ClientUI |1 |Trying to resolve voice.teamspeak.com
2021-05-10 10:42:05.102124|INFO |TSDNS | |SRV DNS resolve successful, “_ts3._udp.voice.teamspeak.com” =(h: dc-9a34d226b974.teamspeak.com p:9987)
2021-05-10 10:42:05.103919|INFO |TSDNS | |SRV DNS resolve unsuccessful, “_tsdns._tcp.teamspeak.com” Domain name not found
2021-05-10 10:42:05.105189|INFO |TSDNS | |A/AAAA DNS resolve for possible TSDNS successful, “voice.teamspeak.com” =(h: p:0)
2021-05-10 10:42:05.106863|INFO |TSDNS | |A/AAAA DNS resolve successful, “voice.teamspeak.com” =(h: p:0)
2021-05-10 10:42:05.107255|INFO |TSDNS | |A/AAAA DNS resolve for possible TSDNS successful, “teamspeak.com” =(h: p:0)
2021-05-10 10:42:05.139816|INFO |TSDNS | |A/AAAA DNS resolve successful, “dc-9a34d226b974.teamspeak.com” =(h: 2001:41d0:700:1c5c:: p:0), (h: p:0)
2021-05-10 10:42:05.140411|INFO |ClientUI |1 |Lookup finished: ip=2001:41d0:700:1c5c:: port=9987 query=voice.teamspeak.com error=0
2021-05-10 10:42:05.140647|INFO |ClientUI |1 |Resolve successful: [2001:41d0:700:1c5c::]:998751.68.181.92:9987
2021-05-10 10:42:05.140805|INFO |ClientUI |1 |Initiating connection: [2001:41d0:700:1c5c::]:9987
2021-05-10 10:42:05.163416|INFO |Core Audio | |No speakers assigned to channels. Please do this in AUDIO MIDI SETUP of osx. Defaulting to stereo for now failure: (0) noErr
2021-05-10 10:42:05.163993|INFO |Core Audio | |Opened playback device with 2 channels at 44100 Hz -
2021-05-10 10:42:05.165173|DEBUG |Core Audio | |BufferFrameSizeRange = 14, 4096 -
2021-05-10 10:42:05.298583|INFO |Core Audio | |Opened capture device with 2 channels at 44100 Hz -
2021-05-10 10:42:05.298958|DEBUG |Core Audio | |BufferFrameSizeRange = 14, 4096 -
Starting Error Reporter: /private/var/folders/rz/440s8nd55_7cr6qtnbfhyc5c0000gn/T/error_report.sh
Saving session…
…copying shared history…
…saving history…truncating history files…

This Version fixes the crash: http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/TeamSpeak3-Client-macosx-3.5.7.dmg

1 Like

I have a big problem. As soon as I try to connect to a server my TeamSpeak crashes.
I have an Apple MacBook Pro 2016 which is on the latest version. I have already reinstalled TeamSpeak but it doesn’t work. Everything works without errors but as soon as I try to connect it crashes.
I also do not get a crash report
What can I do and what could be the problem?

This Version fixes the crash: http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/TeamSpeak3-Client-macosx-3.5.7.dmg


Hello, when I am trying to connect a voice chat by clicking connections and connect, when I press connect the application drops and I have to reopen it. Before the app drops it says trying to resolve hostname.

This Version fixes the crash: http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/TeamSpeak3-Client-macosx-3.5.7.dmg

Ok, thanks, I will try it

Thanks, fixed the problem

Works for me as well - thanks!
… should find it’s way in the official update channel :stuck_out_tongue:

I did the update to Big Sur 11.3.1, but I can’t solve the problem with 3.5.7.
I can’t even access the beta without being put on the waiting list.
Is there any way to solve this problem?

I have a Problem with using Teamspeak 3 on MacOS BigSur on my MacBook Pro (16 Zoll, 2019)
Since January my TeamSpeak keeps crashing when I try to connect to any server.
I have multiple times tried to reinstall it. Furthermore I have reinstalled my device many times and it keeps crashing. Can you help me to fix this issue?