TS client crashes on MacOS when connecting

edit by mod: post moved

I am using a Macbook Air with M1 Chip.
I managed to download and install TeamSpeak 3 version 3.5.6. But when it opens, it tries to connect to the server and the application closes.

Anyone who managed to run TeamSpeak 3 on Macbook with Chip M1 had to do something different to work?

@Škýl Did you do anything to get TeamSpeak running on your M1?

please try the link above.

I was talking about TeamSpeak 5 (the new design) which works just fine

post moved by mod

Hello,

Today my computer actualized automatically and my TS3 not open more.
When I will connect on server my ts3 crash and close.

Anyone have this problem?

Thanks.

Diego Andrade

Try the link which was posted in the Forum Section here

**Edit by mod: Thread moved. Please try to search for issues before posting**

My ts closes by itself when I want to join a server. I am on Mac OS version 11.4. Ty for your answer :slight_smile:

Same here, Mac OS 11.4 Big Sur the solution with the Beta Client 3.5.7 doesn’t work in my case any other idears?

3.5.7 just works fine here on latest 11.4 (non beta).

Are you sure you use the latest client and not the old one?
When does it crash exactly?

4 Likes

Hey, it crashes while connecting to the server.
The client connects to the channel and it times out for other users on the server. You don’t even notice it because you crash during the connection process (app just closes).

OK this describes what we had before.
But we tried again and fail to reproduce this crash with attached client.

Are you really really sure this is the client which was mentioned several times in this thread?

3 Likes

Edit by mod: Post moved. Please use the search function before posting.

I have TeamSpeak 3 64x I’m on a mac and whenever I try joining a server it crashes.

Yes Sir,
i removed the Programm from the Programm Folder and Installed a new Downloaded Version
“TeamSpeak3-Client-macosx-3.5.6.dmg” Mac Version 11.4 (20F71)

No?!

5 Likes

Hey (i thought i tried it with that too and it didn’t work well never mind), okay now the App will Stay Open but i get a connection failed…
But this is an other problem because i get the same on Ts5, on different devices but not on windows 10 with ts3.

Thank you very much

I’m still looking forward to 3.5.7 hitting the release channel! Clicking through the Gatekeeper warning on the beta is getting rather tedious, 3 months and 4 days in…

We are also looking forward to release this version soon

It can’t be that bad because you only have to do it once after installation.

3 Likes

Hello when I want to open teamspeak on my mac 2021 bah it displays the page that I have screen for ideas to solve the problem?

Hold the CMD key and then Click on the App and select Open. This adds the app as secure and won’t ask you next time.

thank you indeed it works but now when I connect to a server my ts is closed directly

This client version will fix that crash.
http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/

1 Like
twitch instagram twitter facebook