TS client crashes on MacOS when connecting

Hallo Guys,

I tried to installed TS3 everythink worked fine but after I click on the “Connect” button the clienet only say “Try to connect to server” after this it crasht with out any error warning.

I use the newest version of TS3 and MacOS

King Regards

Hi, watch up here

1 Like

Mac OS Big Sur 11.5.2
TS version 3.5.6

same as the title.
when i am trying to join the server, the client just keeps shutting down.
tried various servers, same results.
rebooted computer, deleted TS client and reinstalled it, vice versa, but nothing changed

This client version will fix that crash.
http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/

This problem seems to occur in the latest release version of MacOS aswell so it’s not related to the BETA version of OSX.

am using a MacBook Air 2019, OS running Big Sur, as soon as I updated The app starts crashing every time trying to connect to a server, also a blind consumer, and using voice over.
Hopefully there can be some recording of the application on the MacBook.

Watch up for this Post:

1 Like

I have the above-mentioned version of the Mac OS system and since the installation of the TS3 communicator I have had a problem with it. I have the latest version of the TS3 communicator.

The messenger killing error occurs in the following situations:

  • when connecting to the TS3 server
  • when trying to perform a microphone test

Do you have any idea how to fix TeamSpeak 3 killing bug?

Thy this TeamSpeak Version:
http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/

1 Like

Thank you very mutch friend. :slight_smile:

Generally speaking, I run betas from the disk image as long as they work reliably. It makes it easier for me to clean up after I return to the release version. (Notable exception: TeamSpeak’s purple competitor totally fails to run in App Translocation because it relies on rewriting its own app bundle. I have to run it from my desktop instead.)

TeamSpeak 3.5.6 Fresh download and fresh install.
Launches without problems but crashes, without error messages or Apple Crash Report, as soon as it attempts a connection.
It will also crash from within Preferences specifically in Capture - Begin Test.
As mentioned, all crashes are silent.
I don’t see any way to attach a zip file with the logs.
Any help would be appreciated

This Version fixes the crash: http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/TeamSpeak3-Client-macosx-3.5.7.dmg

3 Likes

You, Sir, are a scholar and a gentleman.
3.5.7 certainly fixed the problem.
My thanks.

P

Hello,
my problem is that if I want to join a TeamSpeak Server the application (ts) crashed.
Thanks
Bye

Try this Version of TeamSpeak: http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/

1 Like

Thanks a lot. You are a saviour🙂.

The release version of TeamSpeak also does not work on macOS 12.0.1, which was released on this past Monday. I’m still greatly looking forward to the beta version linked here making it to the release channel!

i have tried to fix by redownloading app several times, and authorising in Security & Privacy, but it wont load?

This Version fixes the crash: http://files.teamspeak-services.com/pre_releases/client/3.5.7-beta.1/TeamSpeak3-Client-macosx-3.5.7.dmg

1 Like
twitch instagram twitter facebook