TS3 / 5 crashes on launch [macOS / Philips Hue Sync]


I was hoping someone could help me with an issue I’m having with TS5. I tried installing it on my MacBook Pro running macOS 13.2.1 (M1 Max), and at first, it got me to the login screen, but it wouldn’t go past that. Now, it usually crashes before even getting to the login screen. I’m not sure what to do anymore, and I was hoping someone could give me some advice.

Has anyone else experienced this issue with TS5 on a similar macOS version? If so, how did you resolve it? I’ve tried uninstalling and reinstalling TS5 multiple times, but the problem persists.

Any suggestions would be greatly appreciated. Thank you in advance!

Since all clients do not work i would guess Rosetta 2 is not installed or running?

1 Like

You got any crash reports from Mac or anything else we can work with?

1 Like

Rosetta 2 is installed and should be working. TS3 in v3.5.7 is running just fine (apart from the occasional crash when I change my macOS audio device/sample rate).

Regarding crash reports, where can I find them? There is no popup after the crash, the window just disappears.

When there is no popup, then there is no crash dump.
In most cases you should get one on MacOS,

That reply is suspect.
TeamSpeak clients only support up to 92 Khz. Maybe your device is set to higher frequency ?

1 Like

I found a crash dump for v3.6.0 if that helps.
All previous versions of teamspeak3 (and I believe even some ts5 ones) worked just fine, even when set to 192khz. Regardless of that, it’s currently set to 48khz and still crashing. v3.5.7 still working as well. It’s just ts5 and v3.6.0 not working.

found one for TS5 as well. now it sometimes doesn’t crash right on start but it crashes after a few seconds nonetheless
TS5 Crash Report

and this error message can be found in the console app for both ts3 and ts5 crashes

AudioHardware-mac-imp.cpp:651    AudioObjectGetPropertyData: the outData argument is NULL

The attached ips file unfortunately only shows a memory error. But not the reason :confused:

Does the TS3 client also triggers an error report?

Good info but this is nothing we use.

1 Like

Tried to find everything i could from both TS5 and TS3. Hopefully that helps.

Also found this in the console again. Don’t know if it has anything to do with it:

RBSStateCapture remove item called for untracked item 393-385-3568 (target:[app<application.com.teamspeak.TeamSpeak3.42516940.42516945(501)>:7356])

finally got those apple crash dialogues as well for ts5.
Hastebin - Log 1
Hastebin - Log 2

after starting both ts3 and ts5 via the terminal both crash with the same log message

TeamSpeak(28180,0x202bc72c0) malloc: Heap corruption detected, free list is damaged at 0x60000355c1a0
*** Incorrect guard value: 0
TeamSpeak(28180,0x202bc72c0) malloc: *** set a breakpoint in malloc_error_break to debug
[1]    28180 abort      /Applications/TeamSpeak.app/Contents/MacOS/TeamSpeak --safemode
ts3client_mac(27910,0x30ed76000) malloc: Heap corruption detected, free list is damaged at 0x600001bae640
*** Incorrect guard value: 0
ts3client_mac(27910,0x30ed76000) malloc: *** set a breakpoint in malloc_error_break to debug
Starting Error Reporter: /private/var/folders/58/0gdln__s6rsg87k5pp3d04qr0000gn/T/error_report.sh

Can you please unplug all external audio devices and try again.

By any chance are there any virtual sound cards installed
Or volume mixer / audio routing tools?

These crashes show more but not the exact reason.
Heap corruption detected could be anything even outside TS client.

1 Like

Looks like the HueSync audio driver was causing the crashes. For now both TS3 and TS5 are working.
Kinda curious to know what caused the crashes though since it worked fine in v3.5.7

Then there is indeed a virtual audio card. It’s needed to control your lights when playing music.

There are changes in our audio code. These also can be found in b70.
Will discuss with our developer for that.


We can reproduce this crash. Writing a ticket for our development.

Can’t tell yet if this will be fixed in next beta or if this can be fixed. ;(


Just found out, that Aggregated Sound devices also cause the crash. Which is unfortunate since it’s required by some software.

I’m having the same issue over here. Also on a mac. I uninstalled huesync and the huesync audio driver, but there is no difference. Any other ideas?

Any other virtual audio devices maybe? Perhaps you could send us a list of your current ones and we could take a look at them?

In Macintosh HD > Library > Audio > Plug-Ins > HAL… which is where I found the Hue driver and deleted it… the only remaining folders are “ACE.driver,” “MSTeamsAudioDevice.driver,” and “ZoomAudioDevice.driver.” Hope that helps. Thanks for replying.

i only have ACE.driver there so maybe it got to do with the other 2

Can confirm this! Crashes with M1 Pro on 13.4 OS X with TS versions 3.5.6 and the new 3.6.0

3.5.7 Beta is working fine. I also have the Hue Sync App installed.