[Solved] Hosting a TS3 Server at home

It’s not only needed to open/forward the specified ports to your device in your router but also for the firewall for the device your TeamSpeak server is running on.
And make sure to select the right protocolls.

For sharing your public IPv4 address make sure your ISP did assign such an address to you or people still won’t be able to connect to your server.

Ok thanks for you reply , but can you please tell me how to do STEP 2 which is below

I have done the FIRST STEP which is to add ts3server.exe . Ok for your information i have made them public which you can see

And I hope that this will resolve my problem

Did it actually solve your issue?

Btw. you should probably remove all the entries which do not exist anymore.
Make sure to tick private or public for the profile depending on which profile you’ve choosed for your network.

I didn’t understand which entries should I remove.

Btw can you pls tell me how to Forward the ports of the server on my PC(can you give a step by step instruction

Better remove all entries and add the one you need again.
Hit allow another app and select your TeamSpeak server and tick the checkbox for private and/or public.
That’s enough for the OS Windows.

Ok thanks for helping me out will tell my friend to connect and I hope it works

I am sorry to inform but its not working .
Can you tell me where to forward the Teamspeak Server ports in my PC , I guess this is the issue

Remove ALL yellow marked firewall rules with the name ‘TeamSpeak 3 Server’.
After doing that just…

…navigate to your TeamSpeak server directory and select your ts3server.exe.
Confirming this action will send you back to the list of allowed application (like on your screenshot).
Tick the checkbox private and public since I don’t know the network type you’ve choosed.
That’s it.

Make sure the port forwarding made in your router is correct.
At least these ports need to opened up/forwarded to the PC your TeamSpeak server is running on.

Service Protocol Local Port (Server) Required?
Voice UDP 9987 Yes
Filetransfer TCP 30033 Yes

Watch out not to accidentally swap TCP/UDP ports.

A summary of all that can be found in this thread:

Sorry but its still not working.
Can we talk in discord or somewhere you suggest. Btw I live in India.

I have done all the steps but when I port check 9987 & 30033 ports its shows closed.

But one more thing there is not Option in the router configuration website that says Port forwarding.
Take a look

Clients are connecting to your server - to your network - using UDP/TCP connections on the specified ports.

These rules are inbound rules not outgoing.

So should I make it incoming??

Can we have a one on one conversation in ur server or stuff like that

pls help me i am creating server but friend cant join i opened three ports and added this ports in firewall but not working pls help me

I’m know this has been asked a ton and i’ve read through previous posts where people tried to get answers. but nothing seems to work.

I just installed teamspeak 3 server and client on my computer (computer 1)
I also installed teamspeak 3 client on a different computer (computer 2)

If i am on computer 1 and tell the client to connect to the server via the internal IP ( 192.168.1.99 ) it will connect just fine.

If I am on computer 2 and using my phone as a hotspot, and then using the teamspeak client on computer 2. using the external ip address 97.xx.xx.xx then computer 2 can connect to the teamspeak server on computer 1.

so far so good.

using the appropriate microphones on computer 1 and computer 2 we can hear each other.

things are going in the right direction so far.

if I go to computer 1 and tell the teamspeak client to use the external ip address to connect to the teamspeak server on computer 1. I get a failed to connect.

I have disabled my antivirus and firewall running on computer 1, just in case that was the issue, but that doesn’t help.

What am I missing?

hi,
the computer 1 is connected to your phone as well ?
some info are missing.

sorry I should have clarified that.

computer 1 is connected via a cat5 cable to the router which has cable internet access.

computer 2 is connect to the phone (the phone is using the data plan from the cell phone company.)

So we agree that the 97.xxxxxxxx ip is from the router right ?

I got my external ip address from google by typing in what is my ip address. I double checked it by opening up the command window and typing in ipconfig.

yeah i understand but this ip is used by the computer 1 ?

yes computer 1 uses that as the external ip address and has 192.168.1.99 as the internal ip address

Quick question i’m trying to reproduce your case actually.
Why would you use the ext ip while the local is working ?

twitch instagram twitter facebook