Why doesn't Teamspeak MAC OS - Allow me to add a hotkey keybind?

Hello,

I have the new macOS Catalina 10.15.5. I started up Teamspeak, and was in a lobby and once I hit it; it wasn’t working. I reinstalled it, and tried to reset the key bind, but nothing. It allows me to click on “No Hotkey Assigned” and once I do, it shows the popup to add the key bind. I click the keys I want but it doesn’t show up and work. Can anyone help please?

4 Likes

Same issue here. I tried removing Teamspeak 3 from Privacy -> Input Monitoring. When I restarted TS it asked for the permission, but when I granted it nothing changed.

2 Likes

I cannot even use the Teamspeak. This is really sad. The new Catalina update screwed it up.

1 Like

It doesn’t let me add the key at all. I get the popup to put in the key bind, but nothing.

Any workarounds? It worked for me last week but today it didn’t work again

Is there any solution for the problem?

Try removing and adding it again, its working fine for me

You have to allow team speak to be able monitor your keyboard.

so im using a mac, and i cant setup a hotkey, it stays on the page to assign a hotkey but doesnt capture any keys, any ideas?

Hotkeys wont work when not allowed in your system preferences.

4 Likes

whoops, disregard last post. it shall be purged in 24 hours.
but posting from the correct account…

Assigning a keybinding on MacOS using the beta client I get a crash, can replicate it every time now.

Can post dump if you’d like? Just let me know where you’d prefer it.

Edit: Just noticed this is under the Teamspeak 3 Client, apologize. Forums are very confusing to navigate in my opinion, also I don’t see a Teamspeak 5 client section? Point me in the right direction if I am as blind as a bat.

I have a computer that is running OS High Sierra and the PTT is not working at all.
We have tried reinstalling multiple times and still nothing. Voice Activity Detection is off as well. We have the capture settings to default. Any help would be appreciated.

Please read Post 10. :slight_smile:

That does nothing for me. It still does not work.

I have the same problem, on the second MacBook already. I would like to know what to do. I have all permissions on server, established hot key, but PPT is not working at all, voice detection is off too. All settings are correct (TS added to accessibility. I can say only that it was working still 6 months ago without any problem, now nothing helps (re-install etc). I would add maybe, that discord works without any problem with PTT (the same settings)

At first I thought that no keyboard shortcuts could be assigned to the Push to Talk option
But in fact you can’t assign any keyboard shortcuts
Whether in the Capture tab or in the Shortcuts tab, a gray rectangle appears and pressing one or more keys does not produce anything.
Fortunately the Escape key works.


Brand new Mac Intel with Big Sur 11.5.2

Every-time I try to make an hotkey through TS, it doesn’t work. I’m on the most modern Mac version (11.5.2), and I’m using the most modern version of Teamspeak, (3.5.7 OS X). Push-to-talk doesn’t work, I have Teamspeak in the accessibility place, and it still doesn’t work. I put TS in every security feature, to allow it to bypass and it doesn’t work. Please give me an update, and whether or not this is an mac, or TS issue. Thanks!

Like WildcatInto, I also Teamspeak in the accessibility place, and it still doesn’t work.

The only way I’ve found to use TS is to select voice activity detection when I want to talk and mute the microphone when I’m done to prevent customers from hearing people in my room. :upside_down_face: :crazy_face:

We can not reproduce this on or machines where MacOS 11.5.2 is running


What we experienced in the past is that keys did not recognized even when the app was allowed.

What you guys can try is following (how to is from my memories):
Open the security center and remove the TS3 client form the list.
Next time you start the client MacOS should ask you if you want to allow/add the app.
Add the app and make sure the checkbox is enabled.
Restart the client and try again.

3 Likes

It’s strange that you can’t reproduce this problem on Big Sur 11.5.2.

I did what you said: disabled TeamSpeak in the Accessibility tab, quit TS and restarted it.
It didn’t ask me to allow anything (I think it only did during installation). So it is not in the Accessibility tab.

So it is impossible to create a shortcut.
So I put TeamSpeak back into the Accessibility tab (with its box checked automatically), quit and restarted TeamSpeak: no change.

Finally, I restarted my Mac, skipping the PRAM - to no avail.

I have a brand new Mac with a clean install (nothing from a backup of any kind) and I can guarantee that I did nothing special.

I even uninstalled TS with Clean My Mac to make sure there was no code left and reinstalled it (this time it asked me for accessibility) but still without the ability to create shortcuts

You must have done something you don’t remember (or are you on a hackintosh?).

twitch instagram twitter facebook